Mac dual monitor BUG

Mac Technical Support
I have a 13" macbook pro laptop, with an extra 21" monitor. The laptop is mid-range in the requirements. In trying to set this up I found that mouse clicks stopped working when I had both monitors running. This was both in mirror mode (where the monitors display the same screen) and regular mode. I tried to click with both the trackpad and a bluetooth mouse. My goal is to play starcraft 2 on the larger screen, has this problem been addressed at all?
Put the displays in extended mode instead of mirrored. And put starcraft in fullscreen windowed mode. I have a Mac Pro, 30 inch display, and 3 other displays and I have no issue at all. See if that works.
One thing to note is that when you run multiple displays, your machine divides the video memory up between the two displays and you'll have lower performance than if you just drive one screen while playing. This is especially evident on laptops, and can make the difference between good and poor performance.

A way to remedy this is to force your system to use just the big display:
  • Close the laptop lid and let it go to sleep.


  • While asleep, plug the laptop into the big monitor. Once attached, click the bluetooth mouse to wake the system (with the lid still closed).


  • The system will now wake up with the big display as the primary (and only) display, which lets the machine use the entire graphics system to run the game and will give you maximum performance.



  • Once the system is up, re-open the lid and you can use the keyboard normally. I'd suggest leaving the screen open, actually, since it allows the system to cool itself properly (and won't cook the screen if the system goes get hot).

    Hopefully that will help some with performance, and should avoid any multi-screen bugs that might be in the game right now.
    Both fullscreen mode and fullscreen windowed mode default to my primary (menu bar containing) monitor. I'd like to use my secondary, larger display. Our old favorite open-the-program-holding-down-option-to-select-display doesn't seem to work. Any ideas?
    @Beorn thanks for your help, I accidentally did that yesterday, and it works!

    Join the Conversation

    Return to Forum