SLI Bug Fix with Ultra Settings

Technical Support
I saw the following post on another forum and yes I can confirm this does work. But of course the shadows don't look quite as good. I tried a random number like 1600 and the frames during cut scenes drop to around 20 but the shadows look a lot better.

Quote from other forum:
Now i poked around in the Varibles.txt (My Documents/StarCraft II/Varibles.txt) and for a random reason I decided to change shadowmapsize=2048 to 1024. Now granted with SLI off 1 8800 GT handles the ship areas fine, why changing shadows to a lower resolutions helps with SLI on I'm not sure. But I have tested it several times and with this i get ZERO interruptions or slow downs in any ship areas on ultra settings + SLI.
I can confirm that this works. I was having the same issue with my GTX 280 SLI setup. It seems that the more you decrease that shadowmapsize=* variable, the greater the benefit. (I tried setting it to 1536, which is 1024x1.5) and I still got a pretty significant performance drop and the scenes become choppy again.)

I noticed in the Escape from Mar Sara cut scene that when Matt Horner is commanding his crew to spin up the engines and brace for warp jump or whatever the frame rate would drop down to about 15-20fps, while the rest of the scene would run pretty much entirely over 100fps. Running without SLI enabled (so just on a single GTX 280) would eliminate the problem at that point, but of course other parts would suffer in performance.

It doesn't seem like a perfect fix though as even with it set at 1024 the frame rate still drops to about 45fps at certain scenes that don't look like they ought to be particularly intense. Like a closeup of Horner's face will cause the drop, while other close ups of his face or other characters faces will still maintain 100fps or so.

Perhaps there may be a driver issue or a software issue in the game itself. I would like to see it fixed though as the shadows do look less attractive this way.
try disabling indirect shadows
I can't believe this is still an ongoing issue!
7 Nvidia driver sets later and still the same !@!!ing issue. And I'm not setting my shadows to Medium when randomly cut-scenes will run at 100% speed for no reason, so obviously the graphics cards have no problem with rendering the scene. Sometimes just watching the same cutscene over again will make it run just fine, but then the next time I want to watch that one it runs like crap.
Indirect shadows are off, SSAO is a huge performance killer in all games so I don't use it for the most part.
I will not be buying the next game if this crap isn't fixed, this is beyond ridiculous and obviously Blizzard doesn't give a !@!!.
snip

I agree.

I'm not turning down my settings when my system can run 3 clients on ultra at the same time.

Obvious bug is obvious, when will it be fixed? Apparently never.

My 9800GTX+ never had this issue.. but that was in beta.

Wish I still had my other system so I could test if ATI cards had any issues.
Hi guys. I'm new to this game.

I've been finding that even setting shawmaps to 1024 (from 2048) doesn't resolve this issue on SLI GTX 460 cards. I'm using graphics driver 270.61.
Ok, I have a solution that works for me.

In variables.ini, I change the line

transparentShadows=1

to

transparentShadows=0

The framerate during cutscenes is just fine.

Join the Conversation

Return to Forum