Mac F keys (F1,F2,F3 etc.)

Mac Technical Support
I cannot get my F keys to work for starcraft 2 on my macbook.
I have checked the "disable os keyboard shortcuts" option in the menu of starcraft and have also checked "Use all F1, F2, etc keys as standard function keys" in my system preferences.
I do not know what else to do! Please help!
Hi SharpStone,

I assume you are trying to get these to be bound to hotkeys, right? Are you using the keyboard on the MacBook or an Apple Keyboard, or a 3rd party keyboard?

I tested this out, and I have both "Disable OS keyboard shortcuts" and "Use all F1, F2, etc keys as standard function keys" and I am able to use them fine. If you have an 'fn' key, can you test if using the 'fn'+F1 key makes it toggle F1?

Also, can you post your system specs, so we know what kind of MacBook you have?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)

________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment
Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact

Pfft! Secret doors, who needs 'em? What do I care about secret doors?... and the unparalleled delights they keep hidden from the world!
Thanks for responding Machkahn. Yes I am trying to get them bound to hotkeys and am currently using the macbook keyboard. I have no idea why why it doesn't work for me.

<System Specs>
Hardware Overview:
Model Name: MacBook
Model Identifier: MacBook5,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MB51.007D.B03

NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3385
Displays:
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: No
Time since boot: 3 days 20:51
Try holding down the Fn key when trying to use f# keys
^^ This please try it if you haven't. This may help us see where the issue may be coming from.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment
Not finding what you need here? Contact a rep direct! http://us.battle.net/support/en/article/contact

Pfft! Secret doors, who needs 'em? What do I care about secret doors?... and the unparalleled delights they keep hidden from the world!
06/07/2012 03:10 AMPosted by Rockkickass
i think this is the most frustrating thing i have ever experienced! pls can someone figure this out

You haven't posted what is happening. You will need to let us know exactly what is going on.
I have a very similar problem. F9 - F12 work, and F1 will work to select idle worker, but Shift + F1 to F4 for map locations do nothing whatsoever. I am using an Apple keyboard.
infiniteloop the default camera hotkeys r f5-f8 try those... if u want to use f2-f4 u need to go to hotkeys in menu and go to global then go to camera and change them there, however u may experience a problem where if u were to make f2 ur first camera hotkey then if u try to make f5 another location it will actually change ur f2 location i havent figured out how to fix that yet
Hi guys,

On my Macbook, after enabling the option "Disable OS keyboard shortcuts" the F1, F2 (F...) keys are still activating OS shortcuts, making it impossible to use as shortcut with Starcraft.

The F1's shortcut will work if pressed while holding the "fn" key, which is not really satisfying as pressing 3 key's at the same time is rather uneasy.

I hope it will help making the game better.

H3r0
Hi people :)

I have a MacBook Pro 15" Mid 2012:
    Processor 2.6 GHz Intel Core i7
    8 GH 1600 MHz DDR3
    Graphics NVIDIA GeForce GT 650M 1024 MB


I am using the keyboard built into the laptop.

I am personally looking for a way to just press for example F2 to select my whole army instead of Fn + F2 or the worst trying to hotkey locations. Because of my pinky is a little messed up trying to press Fn + Shift + not gonna happen :(
I too am having this problem on my late-2008 Macbook Pro. In order to hit F2 for example to select all units I have to hit fn-F2 which is very annoying. Or fn-F12 for example.

thank you,
GreenTea
Do you have your keyboard setup to use the F-keys as actual keys? Apple has a nice article on how to do this: http://support.apple.com/kb/PH10935
Guys, I had the same problema, what I did was change the hotkey from f2 to [`]

Since I dont use microphone button and the [`] button is right beside [1] button.
So its perfect!
Hope this help you.
Cya!
Hey, did you find a way to fix that F5 key not working. I've got my camera bases mapped like you. F2 - 1st base, F3 - 2nd base, F4 - 3rd base, but yeah F5 does not work for some reason.
Hi all, has any one found a solution to this?

My function keys work correctly in Snow Leopard. I upgraded to Maverick a couple days ago and now they totally ignore the 'Use Function Key..." option in Keyboard Properties.

I found this thread in the WOW forum: http://us.battle.net/wow/en/forum/topic/2089280433

It suggested 2 things:
1. Try using the free app KeyRemap4MacBook. THIS DIDN"T WORK.
2. Try using the paid app Paula. THIS DIDN"T WORK.

I usually use the wired aluminum Apple keyboard but I tried the bluetooth keyboard. No difference. Same issue....function keys behave like the non-Standard Apple functions only and ignore the setting in the Keyboard properties.

I've got bootcamp installed so I'm going see if I have the same issue in Windows 7.

So right now I'm w/o my function keys in any app.
Update:

Tested w/ Windows 7 under Boot Camp...same behavior (ignoring the option).

Also, I tested in game as was suggested by Machkan and the 'fn' key + F# does work in game.
Hey I play on Mac OSX.

I'm not sure if you've already resolved this (sorry skipped to bottom), but here's my setup and it works, though it's not typical for most gamers.

1. Select 'Menu' in-game and go to 'Options.'
2. From there select 'Hotkeys' on the left, and then expand (+) the section 'Camera'
3. Here you'll see in the list 'Create Location 1', 'Create Location 2' etc.
4. Since FUNCTION KEYS are a hassle, select 'Create Location 1' and redo as 'Command + Option + 5'
5. Then to map that, scroll down to 'Snap to Location 1' and redo hotkey as 'Option + 5'

That way to snap to your locations you choose OPTION + 5. Though this is an extra key (for typical setups), it gets the job done fine. Now I can actually USE THE CAMERA! HOORaYYYY!!!

Also as an extra tidbit, under 'Options' -> 'Controls', if you haven't already, make sure you check 'Use COMMAND instead of CNTRL.'

Being that I'm on a laptop, the COMMAND key is rather close on game start for me to easily hotkey Nexus, Probes, etc.

Hope this helps :)
Yeah, I was working on getting my F1 and F2 key to work for idol workers and army, but when I hit F2 it just pauses the game like F15.

Anyone have this fixed for them please shoot a reply :D

Join the Conversation

Return to Forum