SC2.exe System Error(Help)icuuc44.dll missing

Bug Report
1 2 3 6 Next
After patch 1.5 optimized my install, downloaded and installed I get this error.

"The program can't start because icuuc44.dll is missing from your computer. Try re-installing the program to fix this problem."

I really don't want to re-install and re-download all the patches. Is there any way to fix this without a re-install?

Thanks,
I saw another thread with similar issues, It was from June and had no answers or replies.

If I do have to just re-install please let me know, so I can get started. Was hoping somebody knew something about this here.

thanks,
You may be able to resolve this issue by deleting and re-downloading the latest installation Tools.

You can do that by deleting the Battle.net folder found in:
-Win7: C:\ProgramData\Battle.net
-XP: C:\Documents and Settings\All Users\Application Data\Blizzard Entertainment\Battle.net
-Mac: Users/Shared/Battle.net

After the directory has been deleted you should be able to run the installer or client again and download the most updated Tools available.
I have the same issue and this did not work at all to fix it.
I have this issue as well, and reinstalling did not fix, and deleting the battle.net folder did not fix. Please help!!
same problem, the program launches but does not load, help
I am having the same issue, I have re-installed twice and tried the folder delete, idk what the malfunction is. if any of you could help id appreciate it!
Hey im haveing the same problem. My system is a core i3 with a 550 ti all new drivers I just recently reformated my hardrive and re installed the game (did this 10/29/12). I tried everything from running as admin, diffrent compatability modes and still nothing. Before I formated my drive it was still happening and one thing that worked was I would launch another game like battlefield 3 right after I pressed play on the launcher, and that got it to work but only happend a couple of times. I tried thesolution above and still nothing. Anyone find a solution?
Right click. Run as administrator. It should download the missing files and fix it in about a minute.
Do what Sellestra said guys. Total genius never would have guessed.
After patch 1.5 optimized my install, downloaded and installed I get this error.

"The program can't start because icuuc44.dll is missing from your computer. Try re-installing the program to fix this problem."

I really don't want to re-install and re-download all the patches. Is there any way to fix this without a re-install?

Thanks,


I just restarted my computer, and now the game is working. Hope that helps.

BTW, my blog is GreenSlugg.com - has nothing to do with SCII (Yet), but I have a lot of DR. Who stuff on there and am adding stuff on a regular basis :)
how do you do this with Windows 8?
Got same problem !! DLL Errors seem a major issue in gaming and software problems !!
As of about a week now I can't play SCII at all, nothing downloads, arcade doesn't work one day everything was fine...then around 15 of December or so it just stopped working????
If you do the reinstall, it fixes the problem for the next launch and doesn't take very long... but it is still a hassle to constantly the installation program every time I want to play the game. Whatever is causing this problem needs to be fixed NOW!
The missing files are in the "Support" folder within the install directory
I had this very problem last night and it had me quite frustrated until I luckily found a fix as well, so I totally know where many of you are coming from. I think the root of the problem, for me anyway, may be with checking the "save replays" box or similar when uninstalling, and it not uninstalling clean. I'm not sure though.

Anyway the first time I uninstalled, I then went to the website to d/l the SC2 installer from my acct page, and I got the error prompt for 'icuuc44.dll missing...'.

I was trying to uninstall/reinstall, run installer as admin, and use the repair tool in help -- none helped at all. I noticed it wasn't until I was hitting the play button in the 1st tier software installer menu that I was seeing the error. Also when I went to program list to try and uninstall/install yet again, SC2 wasn't there. It wasn't until I went to C:\Program Files (x86) and deleted the whole StarCraft II folder that the install worked so that I could finally play (you don't have to wait until "Optimal" to test/play).

I'm not sure if this will work for anyone else, but it may be worth a shot for some of you. GL
I am having the same issue and can't find a fix i also just got my computer and have windows 8
Figure out how to fix this with Windows 8.
I have Virtu MVP on my computer, I had to disable it for SC2 to work, but it works fine for WOW.

Join the Conversation

Return to Forum