An internal error has occured...

Technical Support
Every time I try to start up Starcraft II I get to the launcher, with the error screen of:

"An internal error occured, please restart. If the problems persists please contact customer support"

I was able to at least fully update then log in earlier today, I logged out shortly after since things seemed a bit laggy and I figured I'd just log back in later. Aside from also now being unable to properly launch through Steam, I am unable to play as well.

Any ideas on what's wrong? Should I try to run a repair install?
Same error here
"An internal error occured, please restart. If the problems persists please contact customer support

started after the update with a language error and now this

thank you blizzard
I never got the language error. Just this. So it's not just me, I wonder what could be the cause of it?
I am having the exact same problem. Ug so frustrating :( has anybody tried calling customer support to see what is wrong?
A solution to at least get it to launch, at least for me, is to go into your Starcraft 2 folder and in the support folder launch the SC2Switcher.exe
same
yup ive got the same thing open up starcraft 2 after patch 1.5.0 update. was playing earlier and how i come back and there is an internal error and i need to restart, if problem persist contact technical support yippie.
Exact same thing as OP ,,,,, how to fix? X_____X
i hope this problem gets solved as soon as possible.
guess were all just going to have to wait
From the Known Issues thread:

-------------------------
NEW • Running StarCraft II Migration Setup.exe in the Temp/1.5Migration folder can cause serious issues with your build.
This is being caused thanks to some temp files not being properly removed during migration and we are working towards a solution.
-------------------------

I had the same issue and found running "SC2Switcher.exe" a workaround to the issue. However, after I did a reinstall of StarCraft II it is working fine now.
im having the same issue this is seriously frustrating.
No joke same issue here, played right after the patch fine now I try and get this error. so i should reinstall?
yup. same error =/
hmm my Tuesday is ruined.. Got the same problem
Bump. Please fix this...
Same thing for me. I did a reinstall and it still did the same thing. Its werid that you can play it once after patching and then when you close it and try playing again the error message pops up.
I am having the exact same issue. I played today and tried again just now and having no luck.
is there a fix for this yet
When's this going to get fixed?? Can't play, not even when I try "SC2Switcher.exe". Anywho...

Join the Conversation

Return to Forum