1.5.2 required files are missing

Mac Technical Support
I try to start up Starcraft and then click on play. After that an error comes up saying that required files are missing. How do I fix this.
I am running 10.6.8.
When did this error first start? Were you able to play on 1.5.1 fine?
I could not play after 1.5.1.
Try deleting the variables.txt file in the User Library (not system library):
~/Library/Application Support/Blizzard/StarCraft II
Do I all so delete EditorVariables.txt file. Because I deleted the variables.txt and I have the same problem.
That is strange...

Are you clicking a desktop shortcut to open StarCraft II, or are you opening it directly from the StarCraft folder?
form the applications folder
Can you send me your system information?

Obtaining your System Information and system.log
Snow Leopard (10.6) and older versions of OS X
    1. Hold the Option Key and choose System Profiler from the Apple Menu
    2. When the System Profiler is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location. Make sure the file format is "System Profiler 4.0 (XML)"

Lion (10.7)
    1. Hold the Option Key and choose System Information from the Apple Menu
    2. When the System Information is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location.

Obtaining your system.log
    1. Using Finder, Navigate to /Applications/Utilities and open Console
    2. Click system.log on the left side bar.
    3. On the menu bar, click File, and select Save a Copy As. Make sure the file is saved to the desktop for easy location.

Submitting your system files
    1. Open a new email message, and attach the items as an attachment.
    2. Send the email to macsupport@blizzard.com with the subject as "Attn: TonyM". Make sure you include the Thread title and URL address. This way it gets routed to me so I can take a personal look.

Please note: This method is only used for sending information after files are requested for additional review. This is not to be used a a form of contact, as this box is monitored only when files are requested. No replies are sent from here.
I have doen that.
I did that now what
I checked the Mac Box, but have not received anything yet. Can you resubmit? Also, if the file exceeds 3 MB, the box may bounce the attachment back.
it is a 2MB file and just send it
The logs aren't telling me what is missing :(

What happens when you try to force SC2 to repair itself?

Repairing StarCraft II
    1. Navigate to /Applications/StarCraft II/Battle.net
    2. Delete the Battle.net.MPQ file
    3. Launch StarCraft II

This will force the game to see it is missing data and self repair.
I'll leave this here in case someone else gets the same error.

You're probably missing these two files:
StarCraft II/Mods/Core.SC2Mod/Product.SC2Archive
StarCraft II/Mods/Core.SC2Mod/Index.SC2Locale
Without the first one you get the "Required files are missing" error and you can't log in if you're missing the second one.

I don't think deleting the Battle.net.MPQ file would help because those files are created when the game is installed but aren't re-downloaded when deleted. However, installing the game on top of the existing install should help.


1. Delete the Battle.net folder.
  • Navigate to: 'Mac HD' -> Users -> Shared, Right click Battle.net and 'Move to trash'.

2. Download the Setup from https://us.battle.net/account/management/download/?show=sc2
(Do not use the DVD or an older version of the installer)

3. Run the Setup you downloaded and install the game on the same location it's already installed (Make sure it's not creating a new StarCraft II folder inside the existing StarCraft II folder)

4. The installer will repair and repatch your client but you won't have to re-download the entire game.

After a few seconds and the progress will jump to the same point it was before you ran the installer and you should be able to launch the game.
Thanks for the info eld!
I did this, but when running the new Setup program it just stays on "Checking For Updates" and never moves on to setting up starcraft 2.. hmm
also im on 10.6.3 just updated today and my battle.net file is empty now after I followed instructions to delete all starcraft 2 items before downloading the client again. Now the client is stuck on "ckecking for updates"
09/26/2012 12:22 PMPosted by Conkushtador
also im on 10.6.3 just updated today and my battle.net file is empty now after I followed instructions to delete all starcraft 2 items before downloading the client again. Now the client is stuck on "ckecking for updates"

I believe you need to update your OS to 10.6.8
Correct, in order to use install the game you must be on 10.6.8. Anythign below it may cause issues with some of the tools it uses to install/patch/play the game (i.e. Agent).
i tried the what you said eld but i still get the missing files error

Join the Conversation

Return to Forum