Whats up with the framerate?

Technical Support
Post Limit:
Ok so I have no idea if this is the patch or my computer because this is the first time playing SC2 on my new rig. But I have an Intel Core i5-3570k @ 3.4GHz, 16GB of RAM, and a Nvidia GTX 680. Now this is a beast of a rig and I can't figure out why my framerate dips below 60. I mean I understand that later in the game the framerate would go down a bit because of all the units but when it does in goes down to like 40 and the rapid change in frames make it look god awful. With my specs I should be able to at least keep it at a buttery smooth 60fps in 1v1's at the very least. Big team games I can understand but this is just irritating. Anyone got any ideas?
Make sure you have latest drivers.

also check to see if VSync is the culpurate

If none of those work your gonna have to post your DXDiag information here when its requested by blue


Well when I turn off vsync I get 130 fps but the screen tearing makes it almost unplayable. And even with vsync off my framerate drops an absolutely huge amount in battles going down to like 60 and lower from 130...
I am also having this problem with my game after 1.5.3.

I generally hit 240 fps in-game and now only manage about 120-80 fps. It drops down to 30 FPS in single player maps with a lot going on.
Same speed problems here too.


Well when I turn off vsync I get 130 fps but the screen tearing makes it almost unplayable. And even with vsync off my framerate drops an absolutely huge amount in battles going down to like 60 and lower from 130...


What kind of monitor do you have and how is it hooked in? Vga? DVI?

Also did you update the Gpu drivers?


Yes of course all the drivers are updated. And I have an ASUS 1080p monitor connected via HDMI

Join the Conversation