1.5.3 Game Won't Load After Patch

Mac Technical Support
Mac OS 10.6.8
8 GB Ram
512 MB video card

I successfully downloaded the patch 1.5.3, and it says that the game is up to date and the play button turns orange. When I click the play button, it opens the application (I can see this in the dock), but it quits it immediately without an error message. Then the launcher quits, too.

I read this thread:

http://us.battle.net/sc2/en/forum/topic/6246996723?page=1

But this seems to be a different issue because it's a different patch. I could play under all previous patches. I also tried the proposed fixes in that thread, and they didn't work.

Any help would be much appreciated.
Can you send me your system files and system log after this after this happens again?

Obtaining your System Information and system.log
Snow Leopard (10.6) and older versions of OS X
    1. Hold the Option Key and choose System Profiler from the Apple Menu
    2. When the System Profiler is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location. Make sure the file format is "System Profiler 4.0 (XML)"

Lion (10.7)
    1. Hold the Option Key and choose System Information from the Apple Menu
    2. When the System Information is finished gathering its data, click "File" then "Save As..."
    3. Add your name to the filename, and save it to your desktop for easy location.

Obtaining your system.log
    1. Using Finder, Navigate to /Applications/Utilities and open Console
    2. Click system.log on the left side bar.
    3. On the menu bar, click File, and select Save a Copy As. Make sure the file is saved to the desktop for easy location.

Submitting your system files
    1. Open a new email message, and attach the items as an attachment.
    2. Send the email to macsupport@blizzard.com with the subject as "Attn: TonyM". Make sure you include the Thread title and URL address. This way it gets routed to me so I can take a personal look.

Please note: This method is only used for sending information after files are requested for additional review. This is not to be used a a form of contact, as this box is monitored only when files are requested. No replies are sent from here.
Ugh. Exact same thing happens to me... I click on Play and it says "Up to date". Once the game opens up it immediately closes. Only difference is, im using windows 7
I'm having this issue on Mac OSX 10.7.4 as well... :(

Join the Conversation

Return to Forum