Unable to download authentication moduleHelp!

Technical Support
Prev 1 4 5 6 7 Next
ok u need to rename "Blizzard Entertainment.zip(3)" to "Blizzard Entertainment.zip" , it should work then, and then when u open "Blizzard Entertainment.zip" it should show up as follows

http://postimage.org/image/cusls8uyz/full/

seems like .zip is a extension within the .001 extension type and thinks is a different file when (3) is there

i also renamed it on media fire so anyone else who downloads it doesn't have the same problem hopefully
Now it's saying 'Can not open file as archive'.

http://i.imgur.com/p5jTH8x.png
are those the original zip and part files you got from media-fire or the ones you manually extracted ? , because the ones i used in the image are directly downloaded from media fire and then just changed "Blizzard Entertainment.zip(3)" to "Blizzard Entertainment.zip", because it seems like the parts are associated with something ?

also open it from explorer and not within 7zip / zip extractor, that might help , try using your normal extract tool.
So any update Blizzard?

Been a few days now
Ahh ok TY, this was the reason. I'll be back soon after extraction to test and see if it works.

Alright so I got it extracted and tested it out. It appears that it does work this way except if the map updates after then you can't get into it. There are still a few '...' maps that most likely updated straight after though most maps are accessible now.

http://i.imgur.com/9vKJo0v.jpg - Current available maps on screen.

Looks like I can play my usual custom game again (Aeon of Storms) at least until it updates but it should hopefully be like this before the fix. TY Dark for your help, and I recommend for others to do this as well cause it should fix it for ladder too.
so i have finished uploading the folder, links are as follow -

800 mb part 1: http://www.mediafire.com/download.php?ezy2zuspme7kbbk

757 mb part 2: http://www.mediafire.com/download.php?qa16ad8p5vw21og

total zipped size is 1.55 gb , unzipped should be about 1.84 gb

might need 7zip (had to use this format as it drastically reduced size) extractor
download here:
http://sourceforge.net/p/sevenzip/discussion/45797/thread/75827792

i am not sure if all parts uploaded correctly (u need both before it will unzip) , if any of the parts is corrupted tell me and i will re upload that part

make sure to make a backup of your own "Blizzard Entertainment" folder before replacing it with this one("C:\ProgramData\Blizzard Entertainment" for windows 7).

UPDATE: new Blizzard Folder - current as of 25/01/2013


ok so the above should let you play ladder , and a quite a few custom maps if you need any help just post and i will try to help

note: this is a temporary fix and will stop working whenever the maps next update
I'm having the same issues and seriously where the hack is blizzard technicians when you need them? Just saying flush DNS does not often fix anything....Blizzard response is no different from those you get from calling your ISP to fix router issues.
This will be my 3rd rage post on different forums regarding the same issue. Every forum had a blizz admin at the start who says ''just flush the DNS and restart your comp or switch your modem on and off.'' This is clearly not our problem as everyones game was working fine untill the hacks at blizz decided to change something. Stop telling us to reset crap and fix the gd problem at your end. hard to believe that such a big company has no one clever enough to not break sc2 every bloody month. seriously guys get your act together if you want anyone to buy your products again. i sure as hell have had enough and im sure many others have to.
These mediafire links no longer work, as the download limit has been reached.

Is there anywhere else we can find these files, as I seem to be having the same problem as above.
@eVoRayted

according to media-fire there is no download limit, i tested it using another computer with a completely different internet connection and i was still able to download the files - i will however contact media-fire and find out for sure, but if you could try again and tell me if it works if not i will upload to another site when i get some time

also if the people who have already downloaded it, could upload it to another site it would be much appreciated.
yeah been having this same problem since the patch. at least i can play some custom maps. Won't let me play -mafia- thou, can someone upload it for me?? <3
I've got this issue when I try play on the NA server, but not SEA. From australia here, and I've tried changing DNS etc. made no difference.

Would appreciate an update
@Kurby ok so since i can download content in the morning i will upload, an updated "Blizzard entertainment folder" this should allow you to play mafia etc
please help me guys i have the same problem :(((
Still having the same problem as well as in WoW (error 114)

Apparently if you have an older version of the blizzard entertainment cache it works but for those who installed/reinstalled any Blizzard game recently (within the last week) cannot connect to NA Battle.net.

None of the suggested solutions seem to work and no there is nothing wrong with my ISP or connection to servers in NA. If I can play League of Legends on the NA servers then why can't I play any Blizzard title? It doesn't make sense and has nothing to do us.
I reinstalled Starcraft 2 because the 1v1 menu wasn't loading then I get this problem on my new install.

Is Blizzard going to fix this or no more SC2 for me?
I think they're working on it... for now it's team games and HOTS for me.
So annoying, fix your damn game BLIZZARD.

Everything was fine 5 hours ago then, my stupid game got converted into Trial edition then I reinstalled and now this - "Unable to download authentication module"

I am tired of the daily errors. Playing the game itself is a chore.

EDIT -

I tried everything - changed dns, reinstalled, deleted cache folder, banged my head against the wall, went to church and prayed for extended times, but no nothing is working.
changing DNS is an idea. But after patch 1.5.4, it became nothing. Now neither swarm heart nor liberty can play. Come on, fix it.

Join the Conversation

Return to Forum