Further Help with Framerate, Please. Sigh.

Technical Support
Hi, I was previously helped quite a bit by Velnrak in another thread here regarding my framerate progressively lowering with my games, and after updating my drivers it helped a bit, but it's still an issue. I just had to quit a 4v4 with my friends because it dropped down to 1 fps come the 15:00 mark or so and I'm pretty disappointed about it.

What can I do to fix my framerate? My previous thread has all my specs in it which I can repost. I play on absolute lowest settings, close all other programs, set the SC2exe process to high priority, and use a cooling pad underneath my laptop. What else can I do?

Thanks.
I too have this issue. One of the solutions that has been introduced to me (which i haven't tried yet) is cleaning the fan below your graphics card... But if a blue has a good solution for this, i wouldn't mind hearing it.
I reinstalled this game, having heard they supposedly fixed the FPS problems their 1.5 patch caused. They didn't fix anything, this game is still broken. I absolutely abhor Blizzard for breaking a game that I paid for and showing ZERO results over 6 months.
blues doesnt care about this, they will give you the same answer over and over again, dxdiag, drivers, etc, all things that will no fix this.
I'm thinking the reasons they can't help us much is because the problem is being caused by complicated side !@#$ like how much useless applications are clogging your processor and also in my case how dusty the inside of my laptop is.

When I tried to airblow it thru the vents it didn't seem to get out much dust. I'd open the whole thing up if I wasn't afraid to %^-* something up.
Spirit if you have nothing constructive to contribute to this thread then don't post anything at all. Immature conspiracy theory comments like yours don't help in any way and only serve to piss people off, which may more than likely dissuade them from bothering to try and help you in the future.

01/18/2013 02:35 AMPosted by Spirit
blues doesnt care about this, they will give you the same answer over and over again, dxdiag, drivers, etc, all things that will no fix this.
it has been 5 months since the problem started. constructive posts about the issue stopped about 3 months ago. was that constructive ?

Join the Conversation

Return to Forum