Game Client Version Mismatch Error Message

General Discussion
Prev 1 13 14 15 26 Next
Do i first put the beta key in then log in HotS or first login then put beta key?
Activate the beta key on your battle.net account through the browser, then the game should be active for you
"Your account has no game accounts that can be used in this region. Are you using the correct client?"

I need help. i dont know how to fix this. any idea.
Actually all I did was right click the file selected properties, then at the lower part on the first tab I noticed by the advanced tab an unblock tab was there. I told it to unblock and applied, then just to be safe set it to run as administrator and in xp sp3 compatible mode. Applied the changes and re-ran it, the client started and it began working. Hope that helps.
i always get the error message :
CLIENTSIDECACHE_READ_FILE_NOT_LOCAL

i cannot see the race or difficulty in multiplayer or play games in single player!
all that works is the campaign..

Please fix this issue
Thx, I am getting the message about the error message.

OS Version: 10.8.2
Processor: Xeon 3.33Ghz
Graphics Card: Ati 5870 1GB
Memory: 8 GB 1333 Mhz DDR3
I'm getting the message

"Your account has no game accounts that can be used in this region. Are you using the correct client?"

also, not sure if this is fixed, but it sux to not be able to try it.
I'm getting the message box pop up when I launch the game that my game version is mismatched with the region I am playing in, and when I hit okay and log in the game just sits there doing nothing.

Edit: Never mind, found a fix on the forums which has seemed to work.
I'm getting the message box pop up when I launch the game that my game version is mismatched with the region I am playing in, and when I hit okay and log in the game just sits there doing nothing.

Edit: Never mind, found a fix on the forums which has seemed to work.


And you didnt think it might be nice to share that forum fix with the rest of us?

14 pages of this problem and you find a fix that works and dont share it? What??
I casn't log in in the beta editor, only the game. And even when I'm logged to the beta game client I'm not logged in the editor and still can't log, pelase fix!!!
I'm getting this error as well.
I was getting this error but noticed I have two accounts for some reason. Logging in with one account to live and the other one to beta avoids the problem for me.
I have the same problem. I cannot log into the Editor. I get error message on both the game and editor, except that you can't bypass it in the editor. Both worked a few days ago.
Try to run the repair installer. For me I was getting this error on WoL but not Heart of the Swarm.

Took about 5 minutes and got me logged back in both games with no issue.
I just preordered the game for the beta and now i cant log in getting the region error and cant log into hots. i can however log into WOL even thought i get and error about the regions again.
same issue here, though I suppose Blizz is hard at work on it still.
"Your account has no game accounts that can be used in this region. Are you using the correct client?"
All I get is this message.... :/
I am also having this problem, on both SCII-1 and 2.
same here!!! If Blizz see this-- can you please try to help!!!

Join the Conversation

Return to Forum