Game Client Version Mismatch Error Message

General Discussion
Prev 1 4 5 6 26 Next
01/25/2013 06:55 PMPosted by Ralphy
Still having the same problem. Is it possible that we were never given access to the Beta officially? Even though the system let us it? My account does not show that I Have Beta access. This is the only thread in the Beta forum I can post in.


01/25/2013 07:00 PMPosted by DuoVandal
I have tried logging in like a hundred times and it is not working, what kind of a solution is that? Try again when we have already failed numerous times before even posting here.


Different error.

EDIT: Will update for you in one second Aldrexus.

Update: Error still exists.


Will the two of you please try logging in once more and let me know if you experience a different result?
Same exact result. :*(
I have the same problem... nothing happend.. no solution???
same here, nothing has changed
can login now, still get the client mismatch region error but that can be ignored
I as well have this problem and nothing has yet changed.... :C
Same thing.
http://www.youtube.com/watch?v=SU0vgmf8-bE
still cant login. no change here
01/25/2013 07:54 PMPosted by Aldrexus
Will the two of you please try logging in once more and let me know if you experience a different result?


Will do, one second.

Update: Error still persists. Tricky thing.
I still do not have beta forum privileges for some reason after replying 4 times to the support and I have the same mismatch error message, how did they fix your forum problem? Please help anyone!?
Still having the problem here. I can post to the beta forums so I have access, I just get this error when I try to connect.
Got back from work a few hours ago where myself and three others were having this same issue. I just tried logging in again and I still have no access since the patch. My account still shows WoL PTR. Can't post in the beta forums either...
still got region problem.
I cannot either. I bought the pre order just to be able to get beta access. Turns out I played for 15 mins before the servers went down then when they came back up, I get that message.

Hopefully they will refund my money for now so I can put it towards crysis 3.
Me Too! I'm loving Beta to much to go back to WoL :(
This is a Beta not te actual game so your comment it's kind of irrelevant
01/25/2013 08:31 PMPosted by Greensquares
My account still shows WoL PTR. Can't post in the beta forums either...


You aren't flagged then, if account doesn't show Heart of the Swarm with SCII-1 (or SCII-2) with beta under it then you aren't flagged.

01/25/2013 08:31 PMPosted by Endless
Hopefully they will refund my money for now so I can put it towards crysis 3.


Refund because you couldn't play a beta for a few hours? Not likely. Beta isn't 100% guaranteed to work all the time.
Help please, the support will not help me, they keep telling me to post in the hots forums for help and that they cannot help in regards to a beta! I have played hots I have an account it is not my fault that I cannot post in hots, I am in a bind, I ask for help and am redirected to the place that requires access that I should have and do not. I have both opted into beta, done everything suggested, pre-ordered, there is nothing deficient on my part. All the support is merely redirecting me in circles without much intent of help.
01/25/2013 08:39 PMPosted by DuoVandal
You aren't flagged then, if account doesn't show Heart of the Swarm with SCII-1 (or SCII-2) with beta under it then you aren't flagged.


That's what I was thinking, but I could log in and play just fine until the patch, like some other people are describing. Maybe I just got really lucky and got a few free beta days.
We are probably all not flagged.

Join the Conversation

Return to Forum