publishing a new map issue

General Discussion
just finished making my map and this error pops up when i try to publish the past few days.

game client version mismatch with selected region

The current selected region may not yet be updated to the latest version of sc2, and you will have to wait until maintenance on this region is complete. You maybe be able to continue playing if you change back to the region in which you last updated the game.

anyone know how to fix this?

Join the Conversation

Return to Forum