sc 2 not opening after launcher

Mac Technical Support
The SC2 launcher runs, does the update check and it works fine until I click play. Once the launcher closes, the SC2 application appears in the dock, bounces a couple of times and then disappears without opening. I've deleted the updates and re-downloaded them. I've deleted the blizzard folder under users, and run the diagnostics. Still doesn't work. I've deleted the patches and redownloaded them. This is a clean download straight off the internet that I just installed after reformatting my mac, and updating it.
Any ideas?

Processor 2.4 GHz Intel Core 2 Duo
Memory 4 GB 1067 MHz DDR3
Graphics NVIDIA GeForce 320M 256 MB
Software OS X 10.8.2
Have you tried to reset the SC2 folder permissions?

Resetting permissions on the Starcraft II folder
    1. Select the Starcraft II folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items
I'm also having the same problem as SunTzu. Recently upgraded to OS X 10.8.2. I tried resetting permissions on the SC2 folder with no success. In fact, I was having prolems running SC2 on 10.6.8 and just upgraded to 10.8.2 recently thinking it will fix the problem. But, it hasn't. Can you give me any more suggestions to fix this? Thanks.
Have you tried to delete the Tools folder and retried?
still not working for me... (10.6.8)

Join the Conversation

Return to Forum