HOTS BETA: POST HERE IF YOU GET INVALID LOGIN

General Discussion
Original thread reached post limit so we might as well keep it going..

http://us.battle.net/sc2/en/forum/topic/7864966567?page=1

Its been 4 days since i got my code; and it still is not working. Can we get a response; preferably an ETA; and the whole "we can't provide you that because we don't want to break a promise thing is bull!@#$. Get this fixed."
I also have this issue, please fix.
"Your account has no game accounts that can be used in this region. Are you using the correct client."

"So, still no progress...no update...no nothing? So basically on Friday they said "eh, I guess it can wait until Monday" and went home? Maybe not...maybe they've got their best people trying to resolve it as quickly as possible over the weekend, we obviously have no idea.

As someone who paid money for a pre-order I would absolutely be in favor of a general public release of the beta at this point, rather than delaying until beta shutdown and denying everyone who pre-ordered in Feb."

Yeah, kinda pissed about not being able to play HoTS after looking forward to it for months.
Original thread reached post limit so we might as well keep it going..

http://us.battle.net/sc2/en/forum/topic/7864966567?page=1

Its been 4 days since i got my code; and it still is not working. Can we get a response; preferably an ETA; and the whole "we can't provide you that because we don't want to break a promise thing is bull!@#$. Get this fixed."


Already have a 2nd thread dude.
Your account has no game accounts that can be used in this region. Are you using the correct client.

Amazon Preorder.
*sigh*

*raises hand*

Really hope I don't have to wait till Monday.

Must be a big issue, seems like it's affecting a lot of people and they're obviously having trouble figuring our the root of it.
just got my key but cant log in.. any update on this yet?
same issue as everyone else.
Really hope this gets fixed :( Its been 4 days since I got the key and Its not working, Its kind of deppressing. I hope to hear any news on this being fixed.
02/10/2013 01:33 AMPosted by FireBoltX
Really hope this gets fixed :( Its been 4 days since I got the key and Its not working, Its kind of deppressing. I hope to hear any news on this being fixed.


One of the CM's was giving updates here http://us.battle.net/sc2/en/forum/topic/7864966567?page=16#304 before the weekend started.

So they're obviously working on it, although it seems like they've been having trouble isolating the issue and "it may not be able to be resolved until early next week" kinda implies that there is less people working on the fix over the weekend. Which makes sense but is a little disappointing.
I get the message but i'm able to login and play as normal? o.o
I'm also getting the same error when I try to log on even though I have the beta access under my account. Both SCII-1 and SCII-2 do not work and provide the same error message.
Me too......
02/10/2013 02:06 AMPosted by iEmNick
I get the message but i'm able to login and play as normal? o.o


so when you press confirm it doesn't take you back to the login screen?
bump
02/11/2013 09:49 AMPosted by rQvicious
bump
Please don't, there is already a thread for this, this one is superfluous.
http://us.battle.net/sc2/en/forum/topic/7885318549
Thanks Zappy.
02/11/2013 09:59 AMPosted by Myke
Thanks Zappy.
/Brofist for thread consolidation
lmao; we dont need consolidation fool we need a response...

ill keep this bumped untill its fixed.

Join the Conversation

Return to Forum