The 2.04 Patch Raises Minimum Specs

Technical Support
Although we've managed to greatly increase StarCraft II's graphical presentation without much change to the system requirements, please note that there will be a slight increase to the system requirements when patch 2.04 goes live.

You can compare the original Wings of Liberty requirements to the new 2.04 (currently listed as Heart of the Swarm) requirements on the above support article. Thanks!

Join the Conversation

Return to Forum