Have to repeatedly re-install patch?

Technical Support
Ever since Tuesday, every time I open the SC2 launcher, I have to install the same patch. Even in the same day. For example, I just installed it this morning, a few hours ago. It said completed, and was at 100%. I then proceeded along with my business. I get off, and now that I open the launcher, I once again have to install the same thing.

Note: I use the word "install", because that's the word the launcher uses.
There are some ways to ensure Windows is allowing these changes to be written in the StarCraft II folder. Let us know how it works out.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
Okay I have done that, though I am actually currently re-installing the patch, as I did that. Should I cancel the installation and start again, or should it be okay?
I would just let it go, and see what happens. If it does it again, I'd try running StarCraft II on another User Account in Windows.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
Alright, will do. Also, I'll try to remember to come back to this thread once I have confirmed that it will stay installed, so that you can be updated.

Thanks for all your help, great Druid of the Claw. May Cenarius and Elune be with you.
This problem is actually still happening. I decided to test it, right before I hit the hay, and I still have to re-install the patch.... Again. I followed the directions to the spot and just made sure that I had checked "Run this program as an administrator", which it's still set to from me changing it earlier.

Should I just try installing it one more time, tomorrow, again? Or any other ideas?
Let try deleting the Updates folder in the StarCraft II folder, and see if that helps.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti

Join the Conversation

Return to Forum