Crashes, Lockups, & Unexpected DirectX/OpenGL

Technical Support
Prev 1 8 9 10 19 Next
I've had HotS since launch and am still unable to get past the first mission due to this error. 5 or so minutes in the game crashes and I get the open GL/DX message. As far as playing at low settings I feel that's unacceptable. My setup is more than capable of running it on ultra. WoL ran on ultra since launch without a hiccup as did Diablo 3. I don't have any issues with other games. Its incrediably frustrating I've given up troubleshooting and just moved on to other games until this is addressed. Please fix this!
Greetings all,

Several improvements were implemented with patch 2.0.7 that went live today. Please let me know if any of the issues mentioned in this thread are still occurring.


Loaded the patch today and played again. Had another system hang (forcing a hard reboot) while playing the first training mission on just 'High' graphics. Crash happened about 10 minutes into the game. (SLI disabled with FPS capped at 30 as in last post)

You can see my previous post in this thread with my support files posted.

This game is pretty much unplayable and now a total waste of time. Is there a way to roll back to the game files from a couple of months ago where it was playable? (Still on the WoL) Thank GOD I didn't get HoTS yet because it would have been a total waste.
@butler

I've seriously thought about replying to you but ok, I waste a few mins of my time for your dumb post. First of all it's not frustration in my case, being frustrated about a game sounds a bit weird to me, related to its priority, but you really seem to be frustrated about more than a game, according to your words...

Regarding my critique: Guess you have not the possibility to speculate about my knowledge of IT processes, but anyway, what I said was not that the cs guys here are responsible for this huge bug and the delay in fixing. I have blamed them for bad communication and ignorance of posts related to many problem reports, spread ober EU-english, EU-german and US forum.

No problem for me to get insulted from a random forum guy but it's kinda annoying if people are supporting unprofessional cs of a big company. I hope you do not wonder about continous decreasing quality of software products and their support.
Greetings all,

Several improvements were implemented with patch 2.0.7 that went live today. Please let me know if any of the issues mentioned in this thread are still occurring.


I can confirm that the patch did not fix the issue for me. It still just crashes the game a minute into it.

Hey Roraks can we at least get a confirmation that this particualr issue is being worked on? I ask this because honestly im getting tired of not being able to play the game and i dont even know if its gonna be fixed so i might just get a refund and get it over with. I dont want to sound like a cry baby, i waited for a patch to fix this but the new patch didnt and we dont even have any kind of real answer about this.

Nvidia is also not saying anything about it and i have even had a live chat with their technical support which ended in "go ask blizzard" which is very frustrating since blizzards technical support told me to "go ask Nvidia". All i really want is for you to tell us that blizzard is working on this because, i thought it was pretty obvious that they were but after this new patch and the lack of feedback in this thread im not so sure anymore as to how important this is to you.
Hi

The patch didn't fix the problem: the system still restarting while I play campaign
And please don't tell me that there are lots of minor fixes that are not noted in the patch notes. We are not talking about a minor issue here!
You are correct, it's not a minor issue nor are we treating it as one. However, what is or isn't in the patch notes is a completely separate conversation and not the purpose of this thread. This thread was created to collect information that would help us investigate the reported issues, which I thank everyone for posting. All the information that I collected was passed along.

As I mentioned in my previous post, some improvements were implemented with patch 2.0.7 and that is why I was asking if this was still an on going issue. Now that we know that it is, we can continue looking at things from our side.

All i really want is for you to tell us that blizzard is working on this because, i thought it was pretty obvious that they were but after this new patch and the lack of feedback in this thread im not so sure anymore as to how important this is to you.
I can confirm that we are looking into the reports.

On that note, I'd like to ask those who are still crashing to provide any new error codes they are seeing after patch 2.0.7.

I'll continue to provide what updates I can.
04/03/2013 06:39 PMPosted by Roraks
I can confirm that we are looking into the reports.


Thank you for the answer Roraks i will post my info asap. I really hope this issue gets resolved.

On that note, I'd like to ask those who are still crashing to provide any new error codes they are seeing after patch 2.0.7.


I think for a lot of us there never was or is an error code. In my instance, my entire GPU crashes.
There is multiple issues here, I never kept crashing at the same points in the campaign. It's completely random in arcade maps or campaign and only a single time in ranked ladder. Never once have I gotten an error code because my entire GPU crashes so I can't see anything on my display.

I believe Heart of the Swarm is somehow corrupting some of the GPU's files because of how this issue has spread to multiple games since installing HotS for quite a few people (including me).
I believe Heart of the Swarm is somehow corrupting some of the GPU's files because of how this issue has spread to multiple games since installing HotS for quite a few people (including me).


Hey MegaBlast, i made a post about how i fixed the issue for other games. I had the same problem in all my games until i did that fix and now its just HOTS that is screwed up, you might want to try it out and give some feedback. I cannot promise it will work for you but it wouldnt hurt to try.
@Roraks

I tested single player campaign again and I got a blue screen in just 10 minutes. So for me it is not fixed.

I will try multiplayer but it happens rarely on multiplayer (and I am very happy that it is rare) so I won't know for a while if it happens or not. I have already submitted the information that you asked.

I hope you guys fix it. And thanks for your (and the team's) effort to fix this problem!
Ok spoke too soon. It happened in multiplayer too. I got a blue screen again. So definitely not fixed for me.

Can we at get a rejoin game button after a restart (like moba games.) :D
I am (thus far) pleased to report that I haven't had a blue screen of death since the most recent patch update. I've had the opportunity to run several missions multiple times, even surfing the web for strategy while attempting Achievements, without error. Unfortunately this whole thing has taken so long, I'm still on the paranoid side, saving constantly for fear of sudden (blue screen of) death. But I have to admit, it is kind of awesome being able to devote hours at a time to a game that I love.
One thing I noticed is that the gamr causes far too much heat when it shouldn't. In the leviathan scenes where I was talking to different npcs my 680 was spiking to 70c! That's ridiculous! Other AAA titles that are far more graphically demanding dont even put me over 60c. Is the game even using ram or the CPU (joking, I know it is)? It's just odd that something that isn't as graphically demanding is stressing the card so much. My card never overheats, even with the error, but I don't even want to run the game for fear of damaging it.

Roraks, thanks for the reply. I know that the techs going through code isn't exactly a speedy process, but getting regular updates that the issue is being looked into and is a known issue is great.
Hi Roraks:

Patch did not solve the problem. Since I set my card to stock values (ie not oc'ed), about 2 weeks ago, I hv not had any problems with SC II. However, once I reverted my XFX HD7770 (Blk Edition) to its factory oc'ed values, the freezing came back.
I would really like to finish one hots matchmaking game. Oh wait I did like 3 since the game came out lol..Campaign works fine for me which is weird since a lot of people are having trouble with both
Ok Blizzard, I have played Diablo and Warcraft when they were big names, Now my roomate convinced me to try Starcraft and I went in deep, spent like 100$ getting the old ones and the new ones and now I cant play them on my PC, I actually had to borrow a friends 200$ laptop because it can actually play the game as opposed to my 2000$ gaming PC, Its been almost a month now and I havnt been able to play more then a few hours and I'm not liking this one bit. I remember when Sim City came out and they botched it bad, they actually gave something back to compensate people for not being able to play, I just want my money back or to play the game on something other then a P.O.S laptop. We need results not excuses plz.
Ok Blizzard, I have played Diablo and Warcraft when they were big names, Now my roomate convinced me to try Starcraft and I went in deep, spent like 100$ getting the old ones and the new ones and now I cant play them on my PC, I actually had to borrow a friends 200$ laptop because it can actually play the game as opposed to my 2000$ gaming PC, Its been almost a month now and I havnt been able to play more then a few hours and I'm not liking this one bit. I remember when Sim City came out and they botched it bad, they actually gave something back to compensate people for not being able to play, I just want my money back or to play the game on something other then a P.O.S laptop. We need results not excuses plz.


I understand your frustration brother, i cannot even play one single game without a crash. But by now im afraid all we can do is wait and see if blizzard will fix it, other than that i've been thinking on getting a refund. Also keep this thread alive so they know the issue is not gone.
I was happy player in HOTS campaign, until I reach the level "Infectated". The computer kept on crashing, and I can't complete with that level. Its strange that I never have any crash before that level.
temps are normal and i play much more demanding games on this rig for HOURS and no issues. But, I will get hard hang ups with sound and GFX issues every so often that force me to reboot the system. WoL never had an issue but HotS does. very dissappointing on top of the POINTLESS disc included in the box ( for those who don't know about this - you have to DOWNLOAD the entire game instead of install it . you put the disc in and it installs NOTHING! after calling blizzard they wanted me to update my mozilla....)this is a huge issue with people who play on capped internet.

drivers up to date
Win 7 64bit
ATI 5870 1gig
amd x4 phenom 955 black edition @ 3.7 ghz
8gig corsair ddr 3 1600 ram
MSI 870 - g45 motherboard
Sound blaster x-fi xtreme gamer fatality sound card

Join the Conversation

Return to Forum