Starcraft BroodWar error

Mac Technical Support
I wanted to play my old SC BW today in anticipation of heart of the swarm, but when I tried to install it digitally I received the error that PowerPC applications are no longer supported by my OS.

I upgraded to the newest OS (1.8.2) for Mac so that I could play HotS when it comes out, but it seems that Broodwar is no longer compatible. Is there anything I can do to fix this?
You will want to post in our Classic Technical Support forums for assistance with StarCraft BroodWar.

Just to let you know though, StarCraft BroodWar cannot be installed on OS X 10.7 and above due to compatibility issues.

Join the Conversation

Return to Forum