HOTS - low fps?

Mac Technical Support
I was wondering if there is anyway to allow HOTS to consume more resources. (I know this sounds odd, but i've got a lot to spare here.... and would really like to see the system perform at its best!)

With only SC2 running. I have 25GB of ram free. SC2 would be the only application going, and it consumes only 25% or so of my CPU%.

but in game I still only see 14fps, and then resource stalls every few ms.

I have antialiasing disabled, vsync disabled, mouse confinement and reduce mouse lag disabled.

I noticed in Activity Monitor that SC2 shows up at just Intel and not Intel (64bit) is this normal?

anyhow, Just wish I could get better FPS. I even installed HOTS fresh onto my 256GB Crucial Vertex drive, and fps is still kind of low.

I do have bootcamp installed, may try on the windows side; but I hate switching over.

Model Name: iMac
Model Identifier: iMac12,2
Processor Name: Intel Core i7
Processor Speed: 3.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 32 GB
Boot ROM Version: IM121.0047.B1F
SMC Version (system): 1.72f5

Chipset Model: AMD Radeon HD 6970M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 2048 MB
Vendor: ATI (0x1002)
Device ID: 0x6720
Revision ID: 0x0000
ROM Revision: 113-C2960K-205
EFI Driver Version: 01.00.577
Displays:
iMac:
Display Type: LCD
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

any tips / thoughts would greatly be appreciated!
Reset your SMC:

1. Shut down the computer.

2. Unplug the computer's power cord.

3. Wait fifteen seconds.

4. Attach the computer's power cord.

5. Wait five seconds, then press the power button to turn on the computer.
^ done that.. didn't make a difference.. sigh I might just try it on my windows 7 installation.
any idea why for my computer the game suggests Medium for all settings?

I just saw another thread on low fps and they said the game suggests ultra for them. (but they're on an older mac pro..)
it suggests settings based on gpu, not cpu.. it suggests ultra on my 2008 mac pro but ultra is a VERY BAD idea cause my cpu is too slow to keep up with ultra. I just fine tune until settings are right

the problem with sc2 is it's VERY cpu driven so the baddest gpu in world doesn't really help much for fps concern. the graphics options are somewhat informative though to tell you which ones rely on cpu and which ones on gpu. as such, i can pretty much grank gpu options up to ultra or high and cpu ones to medium or low to correct my fps. try that maybe?
^ if that's the case though, i wish :SC would consume more resources :) because I quit everything, and it only takes up maybe 30% of CPU (in activity monitor)
oh ok, so I loaded up on the windows side too. (im scoring a 7.4 out of 7.9 on the windows index thing)

something i noticed after installing SC there.
--it says default settings cannot be detected. and has the ! by options.

--my mac side did this too. is there something wrong? or does this happen often... (maybe this is why it says medium is suggested? )
SC2 is mainly single-threaded. Your CPU has four cores, one core at 100% = 25% total use.

It's quite common for video drivers to be the cause of low FPS, since the HW specs of your computer should run SC2 without problems. If you have bootcamp, try installing and running it under Windows. If it runs good, check the video drivers for updates.
Good to know! On windows via boot camp I was getting the same results... Maybe something to do with my video card?
I'm running into similar issues, Starcraft 2 WoL ran fine, but HoTS runs terribly on my Mac. I have Pro tower quad 3.2 with 8gb ram and the 5870 gpu.

Some games it runs fine, then others it just lags terribly.
can't explain it... but for some reason now i'm getting 45-50 frames on average.. on EXTREME.

:)

wish I knew exactly what fixed it. but none the less. i am pleased.. and hooked.. i think I played for 12+ hours yesterday... lol
I had the same problem, then I changed the refresh rate from default to 60 HZ
can't explain it... but for some reason now i'm getting 45-50 frames on average.. on EXTREME.

:)

wish I knew exactly what fixed it. but none the less. i am pleased.. and hooked.. i think I played for 12+ hours yesterday... lol


Did you ever figure out what fixed it? I have a similar card, a 1 GB 5850 and my performance is terrible.

Edit: looks like 10.8.3 solved the problem.

Join the Conversation

Return to Forum