After login can't select 3v3 or 4v4

Bug Report
Immediately after logging into battle.net, I can only select 1v1 or 2v2 ranked games. 3v3 and 4v4 are grayed out and unselectable. It's only after I go into another menu and return that I am allowed to do so. Just noticed this as of latest patch.
I have the same issue i have no idea why
Same for me
I have the same problem, but reversed.

I can only play 3v3, 4v4, or FFA in Unranked or Ranked gamemodes. I cannot select 1v1 or 2v2, inexplicably. Someone else was having the same issue, and said to run the repair tool, which I did. It worked at first, but then the problem has reappeared, and now the repair tool doesn't fix the problem.
same here too...
Me too :(
I have had this problem for over a week. The matches I can play in ranked and unranked varies from day to day. Last week I could play anything but 2v2. Then it was only 3v3 or 4v4. Yesterday I could only play 2v2 and when I logged in today I can only select 4v4.
I'm having the same issue, but the matchmaking options are randomly greyed out at times. I have WOL and HOTS installed but I'm playing WOL ranked matches, if that helps.

After logging in and going to Matchmaking, sometimes 1 or more of the "1v1", "2v2", "3v3", "4v4" options will be greyed out and unselectable. Yesterday I could select 2v2 and 4v4, but today I can only select 1v1 and 3v3. If I exit the game and re-open, the selectable options will be different. It is never consistent. This started after the last major patch like 3-4 weeks ago.
This happens 2 me all the time, I just relog and it goes away.
Change Region and then come back. This fixes it every time for me.
They know about the inability to select specific game modes.

The 4 biggest suggestions from the community are are 1) log out and back in, 2) switching from one region to another and back again, 3) run SC2 in admin mode, 4) run the Repair Tool.

Good news:

http://us.battle.net/sc2/en/forum/topic/8796679671?page=5#95

Join the Conversation

Return to Forum