Achievements and Portraits not loading

Technical Support
Prev 1 9 10 11 12 Next
EDIT: Never mind. Please delete.
Recently I've been experiencing this. Attempting to browse to

http://us.depot.battle.net:1119/000000test.txt
http://us.depot.battle.net:1119/400000test.txt
http://us.depot.battle.net:1119/800000test.txt
http://us.depot.battle.net:1119/c00000test.txt

Results in "connection was reset".

I can ping us.depot.battle.net so I can actually see the server. Its IP is 72.21.81.63
Browsing to us.depot.battle.net shows "forbidden" so I can access it on port 80.

I disabled Microsoft Security Essentials and Windows Firewall... still cannot see it.

I opened 1119 and 1120 ports on my router.

To verify that I can see those ports I ran a Vuze server under ports 1119 and 1120. I then went to https://www.grc.com/x/ne.dll?rh1dkyd2 and scanned ports 1119 and 1120 which confirmed that those ports are open and accessible from grc.com (which means they're accessible from beyond my ISP... which is Bell Canada)

I asked a friend who lives about 30 miles east of me to visit

http://us.depot.battle.net:1119/000000test.txt
http://us.depot.battle.net:1119/400000test.txt
http://us.depot.battle.net:1119/800000test.txt
http://us.depot.battle.net:1119/c00000test.txt

And he gets test successful on each. He also is with my same internet provided (Bell Canada).

Iiiiii am at a loss why I cannot reach those servers under 1119/1120 but can under ping and HTTP.

It happened roughly at the time that Patch 1.3, 1.3.1, and Season 2 started... maybe my DNS is pointing me to a decommissioned server that still responds to pings?

Is 72.21.81.63 still an active us.depot.battle.net server?
Turns out after further testing that friends who can play Starcraft2 no problem also ping us.depot.battle.net to 72.21.81.63 -- so something else is preventing me from connecting.

Ideas why I can't load us.depot.battle.net:1119/000000test.txt and its friends since around the start of Season 2/Latest patch? (*Keeping in mind what I've tried in the post above*)

Recap of symptoms I see:

1) Profile pic is blank.
2) "Achievements are disabled until further notice."
3) Can only play SOME custom games like Nexus Wars, Desert Strike... others don't appear on my list (appear as "..."). If I'm in a party and they attempt to join one of those "..." games -- I am not prompted to join the game -- all I can do is cancel.
I have not read this entire thread, but for about a month I was having the same issue. Log in, "achievements Temporarily unavailable"

I discovered in my StarCraft folder an executable to Repair StarCraft. When I ran that, I ran SC2 again and bam, everything was back!

Again, I didn't read all 10 pages of this thread, so if this was posted already sorry!

This happened after I let someone log into SC2 under a Guest account, so something must of corrupted.
Repair didn't fix it initially... but I tried again (even though I don't know how it would mess up Firefox too). Still didn't fix it.

Yet the patch this morning did.

And it now says 00 test successful. when I go to the first link in Firefox.

I don't know why.

Seriously. That makes zero sense to me. Starcraft is never even running when Firefox works or doesn't so it SHOULD be purely a networking issue between my computer and Blizzard's servers... and patching a non-running software shouldn't affect that. But the problem is fixed now so I'm happy. Confused, but happy.
I am having this issue. Only Multiplayer works. Achievements and Single player are grey'd out and whne I close SC2 it stalls and I have to Ctrl+Alt Delete and force close it. I ran the repair and tried it again. Everything seem'd to work intill I click Achievements then everything except Multiplayer went grey. I was following the trouble shooting instruction but it is really confusing and frustrating.

Edit: Actually I went back into SC2 and I was wrong. When I click on Multiplayer Singleplayer and Replays go grey. When I selected Single player after a restart and selected continue compaign it shot me back to the main screen and thigns grey'd out. I hope people who are more computer savy can get info to Blizz and this fixed. Sorry I couldn't be of any help. I just wanted to vent what was going on. One last thing. I noticed that when I have SC2 on the CPU is using double the amount of resources it normally does. Not memory but CPU. On my i7920 quad core it notmally uses upto 23% not it goes from 45% to 53% !

Edit: This is good but dumb. After writing the last edit I was alt+tab'd and when I went back to SC2 I was able to access everything in game out of knowwhere !? Weird. The CPu usage is still high but perhaps that is something on my end. Err thanks Blizz ??
C'mon guys! I have had this issue still since the game came out, and you just announced Heart of the swarm! Fix this already! :(
I am getting very tired of this! i have been a very loyal fan of this, yet blizzard has made little new effort to fix this issue, so long as you include them blaming other things other than themselves. Im very tired of this!

I just installed this on another crap computer and they don't have this problem. I have been trying to get more of my friends to join but this is a very big disappointment when it comes to how blizzard treats its followers
Was having the same issue, followed all the instructions wasnt fixing anything till I ran as Admin. Achievments showed up even the ones I earned before fixing the problem.


Thanks
BUMP for great justice!

Blizzard really needs to get on fixing this issue already!

(also i tried running as admin and no changes)
@ Syviren If you've had this issue since the game came out which was last year minus 7 days, there are 8 pages with possible solutions and people have stated that the problem was fixed.
@Mr blitzy I have tried ALL of them. ive been posting about this since the game First came out. Check the posts on this and other forums
Is there a reason why the achievement icons and things of the like aren't just distributed with the game client? Or would that make too much sense?
I think it would make too much sense :p
So after speaking with a friend who also plays SC2 and is experiencing the continued dropped games, I decided to try something. I launched a free VPN service I use, called Hotspot Shield (http://www.hotspotshield.com/). It's not bad, but if you close the original window, you will get popups from time to time. Then I fired up SC2, and would you believe all the achievement icons populated!?!? I close out of SC2, then shutdown Hotspot Shield, then relaunch SC2, and the icons are all still there. And also, even after I restart Avast, the icons continue to populate.


Confirmed! I'm not sure why this works but after trying everything else on the thread and having no success I gave it a shot. Installed the free version of HotSpotShield, turned it on, ran SC2 and Achievements were back. Immediately exited SC2 and turned off HotSpotShield. I'm keeping HotSpotShield around in case the problem comes back but for over a week now I have had no further problems.

Thanks Theodisus!
hrlp!
Hello All,

I am having a similar problem where my multiplayer screen wont load. I can't find a ladder match or a custom match. I can't view my leagues or ladders however my achievements load. I have tried updating the time to all of the different time options, I have tried disabling the firewall, I have checked all of the browser tests (successful) but can't download any of the wafl files.
I have the same problem after upgrading to Windows 8.
When I try to log into SC2 it will come up with the "internet down, Play Offline" error or Global Internal Error.
Normally I can log in the third time but portraits and achievements don't load and can't start any game.

Edit: I just tried SEA and it worked like normal. I guess I am one of those who can't access NA server right now.
What happened? I DL the patch and my whole game goes to crap. Stuttering, portraits gone, achievements not accessible or loading, loss of connections to games. Is this going to be fixed?
The achievements are not loading again. I connected through hotspot, and the problem has been fixed (until the next patch).

It was mentioned before by Bliz, that the ISP caching is based on filesize, and an incomplete portion of the data. I realize that in a perfect world, the ISP should cache properly, but since they do not, have you considered slightly altering the filesize of any files which change in a patch? I am not familiar with the implementation, nor what complexities this would add, but it could likely fix any/all caching problems, regardless of how absurd they are implemented.

Cheers!

Join the Conversation

Return to Forum