After 2.0.10 patch, unable to choose high res

Mac Technical Support
Post Limit:
Just updated to 2.0.10 and not able to choose video resolution higher than 1920x1080.

I have a 30" Dell monitor that I was playing at 2560x1600 just yesterday.

Please fix!
me either, please fix this. everytime I launch my sc2, my monitor goes black. I don't have this problem with anything but SC2. wtf?
Chat support suggested that I update my video drivers (bundled with Mac, up to date), edit variables.txt for custom height/width (didn't do anything). Works fine on my native Macbook Pro screen. I'm connected via DisplayPort. When I quit SC2, my monitor's resolution is messed up and I have to reset the whole configuration for my external for OS X native desktop. Very annoying.

She made a bug report with IT.
Thanks for the report.

Could you tell us your video card model and your OS version?
You can try this workaround until we fix this problem.

Open the Terminal application and enter the following line, followed by the Enter key:
defaults write com.blizzard.starcraft2 DesktopModeIsDefault 1

This needs to be done before launching SC2.
i talked to customer support today too and he basically said blizzard doesn't support macs using external displays. that was the stupidest reply i've ever heard. he said just to play on my MacBooks display even though i have been using an external 1920x1200 monitor since the games launch. also starcraft only shows 16x9 resolutions. when my monitor uses those resolutions the game appears way too contrasted. everything becomes either black or over saturated. i played with variables too but even though the resolution i choose stays in the txt file the game will still only do 1920x1080
i tried this and it does make my game run at the old resolution but now my game us unplayably slow.
You can try this workaround until we fix this problem.

Open the Terminal application and enter the following line, followed by the Enter key:
defaults write com.blizzard.starcraft2 DesktopModeIsDefault 1

This needs to be done before launching SC2.


THIS FIXED IT!

I entered that command in Terminal.
Started the game, chose 2560x1600, it wasn't fixed yet though
Switched to Windowed Mode (Command-M)
Desktop resolution was messed up, so I had to unplug my DisplayPort and plug back in, then reset the desktop resolution
Switched back to Fullscreen mode, and the game runs at 2560x1600 now!
If you could tell me your video card model and OS version that would be very helpful.

Also how do you connect your monitor? HDMI, DVI, any adapter?
You guys are all using the 30" Dell monitor, right?
I'm seeing this same problem on a Mac Pro with an LG L246WH monitor (native resolution is 1920x1200, a 16:10 ratio). ATi 6870 video. Connected by DVI port on the card to a HDMI port on the monitor using a ordinary DVI->HDMI cable.

As it happens, I did a reformat and clean OS X install last week, so the whole machine feels pretty fresh. Updated OS X to 10.8.4, then installed SC2 fresh and updated SC2 to 2.0.9 (I presume). Everything worked fine at 1920x1200, looked beautiful at Ultra.

Updated SC2 to 2.0.10 during the week sometime, but only ran it for the first time last night. Resolution had reverted to default. The only resolutions listed were all 16:9 ratios, 1920x1080 being the largest listed. Tried a few things, including editing variables.txt manually (but my change was ignored).

The defaults write com.blizzard.starcraft2 DesktopModeIsDefault 1 advice worked and returned all my 16:10 resolutions to me – thank-you.
i had similar experience on 10.9, on a Monoprice 27" 2560x1440 16:9 monitor via Minidisplayport
OS X 10.8.4

NVIDIA GeForece GT 330M 512 MB

Mini DisplayPort to DisplayPort cable

Dell 30" monitor
Thanks Enceladus, we will fix your problem.

Jef and Lacrymist can you tell me what is the maximum resolution that you are seeing in the game?

Thanks
Lacrymist, we tried your setup and we could not reproduce the problem.
2560x1600

Macbook Pro lid is closed, and system bar is moved onto the external screen.

It's no longer a problem after I did "defaults write com.blizzard.starcraft2 DesktopModeIsDefault 1"
the terminal command also worked for me,running a mac pro 4.1 with a GTX 680 card installed.

Join the Conversation