Website Bug Report

Apr 15, 2013 Posts ending up in the wrong place. Quick rundown of how the problem happened *this* time. I reply to someone in ROGUE forum. I hit post. I get a 404 page not found error. I hit the back button, F5 refresh the page with the thread on it(sometimes this fixes it and my post ends up on that thread at the end there, it just failed to refresh after posting properly). While I'm refreshing the thread in one tab, I swapped over to another open forum tab that I have open on a thread in the UI AND MACRO forum. Lo and behold, the post I made in the ROGUE forum is in the UI AND MACRO forum. So... how does that work? This seems to happen randomly here and there, and this is just how I managed to get it to do it THIS time. Keep in mind, I usually have anywhere between 2 and 12 forum threads open at any given time, all on different threads. Usually one of them is open to General Discussion, so I don't have to keep navigating the current tab to get back to the main forum page. I close each thread tab as I finish reading the thread. Your forums don't like this apparently. I am using Firefox 20.0.1, fully updated. I am using NoScript. Battle.net is allowed, Google Analytics, however, is not. I also run Cogshanks. I thought it was one of them at some point, so I disabled them. Still does it. Does it in IE as well, where I don't run plugins. Ir's the forums. BF also says he's noticed it, and he doesn't run plugins. He uses IE.Arcata0 Apr 15, 2013
Apr 14, 2013 I can't upgrade my armor D: i just got this new peice of armor and im planing on upgraiding it but when i got to the guy in the shrine of two moons ,within the hall of secrets i cant interact with him it just says "voidbinder shadzor <holographic projection>" and im not able to upgrade my armor now and i dont know how or why its not letting me but its been 6 months now and im getting tired of waiting for this to be solved Blizzard please help !!!!!Deathhornes1 Apr 14, 2013
Apr 14, 2013 Profile hit bug On my profile it says I have 16.14% hit chance, 4632 hit adds 14.88% hit. In game it says I have 14.88% hit 4,632 (+13.62% hit chance) Now, I understand the 13.62% because that comes from my actual hit. The extra 1.26% comes from the 428 expertise I have on my wrists. So where the heck is the EXTRA 1.26% coming from? If that's a bit confusing for you... 14.88-13.62 = 1.26 16.14-14.88 = 1.26 My in-game hit chance says 14.88 (13.62 of that is from the hit attribute, 1.26 from expertise) My website profile hit chance says 16.14 Clearly it's adding my expertise TWICE, which in my eyes is a profile bug.Erzale0 Apr 14, 2013
Apr 13, 2013 PLEASE FIX MY ACHIEVEMENT POINTS I have 18575 achievement points in the game, and armory has me at 16290. Is there somebody that can please update my armory page for Ysera-US correctly? Thanks..BuckBücknütty0 Apr 13, 2013
Apr 13, 2013 Hi I am not sure if this is a bug on armory but it says on this char's armory profile completed Hagara tho stormbinder on normal. Back in cata I only ever did LFR, and I am pretty damn sure my account wasn't compromised cause I didnt stop playing till MoP and only for a month. not to mention my Real id email is only used for wow and important stuff. not guild sites or other stuff. all different passwords tooZolavix0 Apr 13, 2013
Apr 13, 2013 lag Do you think you can fix the lag prob in stormrage?Rockgo0 Apr 13, 2013
Apr 13, 2013 "World Killing Blows" not updating properly Kills that you do in The Jade Forest, Krasarang Wilds, and Deepholm don't update your armory statistics (specifically Armory -> Achievements -> Statistics -> Kills -> Killing Blows (World Killing Blows)). However, it does update properly in Kalimdor and Eastern Highlands (including Mt. Hyjal and Twilight Highlands).Lohgãn0 Apr 13, 2013
Apr 13, 2013 Exalted Argent Champion Exalted Argent Champion of the <Alliance|Horde> is displaying all criteria (ie exalted with Argent Crusade and Champion of the <city faction>) completed for characters that have not even started the Argent Tournament. Exalted Champion of the <Alliance|Horde> may also be displaying all criteria completed incorrectly. (Untested as this achievement is not displayed if one completes the above higher level achievement). Whereas Exalted Champion of the <city faction> is displaying completed criteria correctly.Mavra0 Apr 13, 2013
Apr 13, 2013 Online profile and certain stats not correct. Noticed about a week or two ago that my mains achievement points are no longer showing correctly. All characters on my account when viewed on the website are showing 10980 points. Yet my main and the character than I unlocked 99% of these points is only showing 9760.Endangerous0 Apr 13, 2013
Apr 12, 2013 Achievement point total Hey there, the armory has my achievement points listed as 16270, and my actual point total is 18575. Blizzard said I had to get in touch with armory because it has nothing to do with Blizzard. Please update my score so I can return to the top of ysera, thanks.....BückBücknütty2 Apr 12, 2013
Apr 12, 2013 Achievements under portrait not accurate They don't equal the number listed on my profile page, and both are lower than the number listed in game (this is the highest, I'm assuming that's for all characters). Additionally, my profile shows I have no achievements related to the battle pets, which is inaccurate.Êverest4 Apr 12, 2013
Apr 12, 2013 worldofwarcraft.com Going to worldofwarcraft.com is no longer redirecting properly. It ends up at http://us.battle.net/wow/en/new-site and says "Uh Oh", page no longer exists.Growltiger0 Apr 12, 2013
Apr 12, 2013 Character Selection Bug Every time I visit the battle.net/wow website after a few hours, my character selection list becomes scrambled and my default posting character is set to something new (usually a low level toon or alt). I always have to change it back to this one, or one of my other main's/characters. Is there some way to fix this? or is this a website bug? And I know someones not messing with my computer while I'm away because usually I'm exercising in the room over or simply playing WoW.Leftelbow0 Apr 12, 2013
Apr 11, 2013 Cannot connect while using warcraft remote I just got this error after several times of trying to log in and getting disconnected. Is the remote this website? I closed this browser and I was able to join.Bamnit1 Apr 11, 2013
Apr 11, 2013 Mounts not in the game still listed We still have a lot of unused mounts listed under the not collected section of the armory including the other colors of heavenly serpent, crane, and the numerous water striders that still say u get at exalted but never made it to live. I understand blizz makes multiple colors of mounts in case they need one, but it doesn't need to be listed as available if it isn't. =/Starscreamer0 Apr 11, 2013
Apr 11, 2013 Auction house not showing any thing I have auctions in game on this char quite a few but on the armory page it says I have 0 active 0 sold and 0 in my mailbox.Seventhwinds0 Apr 11, 2013
Apr 11, 2013 Bugged Cape on Blood Elf Females After 5.2 hit, I have been noticing weird movement patterns on the longer capes for my Blood Elf Female. Before the patch, they flowed fine, but after it seems like when I run the cape goes one way while the body goes the other. It looks unnatural. This isn't intended, is it?Mitsune3 Apr 11, 2013
Apr 10, 2013 Postmaster items not in mailbox Kuwilei0 Apr 10, 2013
Apr 10, 2013 EotS victory stats For some reason my ingame and armory statistics only show 3 victories in eots. For a while I was thinking alliance was just that bad at it.. But I know I've won a few this week and the number never goes up. This is slightly embarrassing. Please fix.Reverator0 Apr 10, 2013
Apr 10, 2013 Display Only Character Achievements Issue It appears that the in game options to "display only character achievements" is not currently being honored by the forums and armory. As an example, I can see the Tanaris Quest completion achievement on Phee's armory (as well as a couple alts I checked) despite the fact that I completed that achievement today on a completely different character. I did also check to see if I was still seeing account wide achievements even if I logged out of the Battle.net website, and I still saw the account wide information. I know that this was working before, although I'm not exactly sure at what point it stopped working.Phee27 Apr 10, 2013
Apr 9, 2013 Battle.net Music Player Busted Wasn't sure where to report this, since I'd need a SC or Diablo key to post in the battle.net forums, but hopefully someone can forward this on to the right people. The Battle.net music player at http://classic.battle.net/window.shtml has been busted for the last few days. The player opens, but it has no tracks listed. This is a problem. The Bnet music player is an integral part of my workflow. Without it, I would shrivel and die. I also wouldn't get any work done. Please fix as soon as possible. Also, if possible, I wouldn't mind someone adding in the classic Warcraft II soundtrack to it along side the old SC and Diablo tracks. That stuff was cash.Glóredhel1 Apr 9, 2013
Apr 9, 2013 Hunter Pets Not Appearing In Armory I've made an observation that for a while now I cannot view mine or other hunter pets in the armory. All the names and what types they are, are listed, but the picture of the pet does not show.Shana0 Apr 9, 2013
Apr 7, 2013 "That's not a rock" quest bugged [Arie Peak Server] Must kill 50 hatchings. Didn't matter how many I killed, it would not progress past 33/50. Also another weird thing happened. I was on my mount looking for groups of these things...which by the way, are extremely rare, and when I was right on top of them just before I attacked, all 8 mobs died instantly, and I had done nothing. Needless to say I did not get credit for the kills. It took forever to get to 33, and I hate the thought of abandoning and restarting. So I don't know if that would fix it. I'm just going to drop this masochistic quest period.Bantor0 Apr 7, 2013
Apr 7, 2013 Strange alt-main achievment point bug. The Armory started a strange bug for me this week... I started a new DK alt here: "http://us.battle.net/wow/en/character/area-52/Daylah/simple" For some reason my new Alt is showing this characters Achievement score of 5965 while this character "Ghostmourn" (my Main.) now displays "4910" which is correct for Daylah. Its like the database tables got switched or something.Ghostmourn2 Apr 7, 2013
Apr 6, 2013 Web auction lockout bug In the last few weeks, I've noticed a problem with the lockout between logging into the game and using the web auction. It's false alerting far too much. I use the web auction a fair bit (no surprise, considering my name, ;) ) and even if I switch to the web home screen, wait two minutes and then attempt to log in, I get the message "You cannot log in while using ..." I've even had a case where I hadn't touched my web browser in several hours, it wasn't at any of the auction screens, and yet when I tried to log in I got that message. Or another instance where I was in the game, logged out, logged back in again on a different alt, and got that message. Please investigate tying to fix these false alerts, they tend to be a little irritating.Sotheby0 Apr 6, 2013
Apr 6, 2013 website auction house problems? I was browsing the auction house buying up some materials to finish off my ways cooking when bam !!! Couldn't buy out anything anymore. I tried restarting my browser nothing...tried logging out and back in nothing. tried logging out and back in but saved my authenticator on this computer for 30 days thinking maybe it had something to do with that...nothing. I can't post auctions, bid or buy out anything. Anyone else having this issue?Dlm1 Apr 6, 2013
Apr 5, 2013 Incorrect EotS record on armory profile Greetings fellow adventurers and Game Masters. Just wanted to bring attention to the fact that the Eye of the Storm record on my PvP page of the armory that shows all records for the different battleground done in RBGs is definitely incorrect. It shows me as 0-35 all-time in there. And while many could and have accused me of being bad, I know for a fact I have not lost 35/35 games in EotS. If anything at the least I've won/loss half of them. I know for a fact that I've won a few because of winning strats I've tried out with my group and successfully executing them. All other records seem to be accurate, other than the EotS record. I know in the grand scheme of things it means absolutely squat and it hardly matters if at all. However, all bugs should come to the surface to be recognized; no matter how petty. (unsure if it's happening/happened to any of the people I ran the RBG with or anyone else) Thank you, and may the Fel be with you.Felmen2 Apr 5, 2013
Apr 5, 2013 Changing Personas doesn't change immediately. When I'm on the forums and I change which persona I'm using, I get a small bit of activity from the browser, then it stops. Now, in the background, the persona I'm using has changed, but it doesn't display the new one at the top of the page until I load a new page. If I change during the creation of a post, it won't show the new personality until after I've submitted the post as the new personality. This is on IE9 & 10 under Win 7 64 Bit.Arrataz1 Apr 5, 2013
Apr 5, 2013 beta utility recording wrong hard drive. the issue and reason i am submitting a ticket is the battle.net beta upload utility is grabbing the wrong hard drive size info. its pulling a secondary drive for its info which is incorrect. basically its saying i only have 10gb free which is correct for that drive but its just a backup drive and should not be considered for free space reasons. my C drive has about 150 GB free which is a better representation of free space available for my comp. not sure if this info is used for beta eligibility but if it is this is a major problem.Zathrxx0 Apr 5, 2013
Apr 5, 2013 Blizz...fix my armory seriously... Look at me...I look stupid as hell. Not only do I just stand there like a mannequin...no action pose no nothing..but I'm wearing a BACKWARDS CLAW. Come on now.....can't even look at myself in my badassery little wolverine awesomeness.Lavalicious1 Apr 5, 2013
Apr 5, 2013 Extra character shows in my website profiles When I click on the profiles at the top right of the website, I see a level 6 Draenai Shaman named Gigastorm on the Proudmoore server that I deleted about 3 years ago. This character also shows up in the armory. Is there a way to have this character removed please?Sodamyte0 Apr 5, 2013
Apr 4, 2013 My armory is bugged My hair isn't like this. Please fix, I use armory a lot.Ranza5 Apr 4, 2013
Apr 4, 2013 Mature Language out of control? I attempted to name a Spirit of Competition "Transcendental" to embody the ideal of an unstoppable force meeting an immovable object. I abbreviated it to "Transcend," then to the point of "Trans," and it still was violating the 'mature language' filter. I'm not sure I understand how this is an issue.Mengskraun1 Apr 4, 2013
Apr 4, 2013 Armory Bug My armory is bugged. I should have around 14,800-15,000 achievements but when I go into my armory it is showing me having under 13k. Thanks for your time.Waffels0 Apr 4, 2013
Apr 4, 2013 Armory guild news feed broken. The guild news feed now says things like "Zileex obtained [Gear]. in 45 minutes". How can it be reporting something that will happen in 45 minutes if it still has not happened yet?Zileex0 Apr 4, 2013
Apr 3, 2013 Bugged armory Since 5.2 launched, my armory no longer shows my shoulders. I did some tests and found that it will show my shoulders when they are not transmogged or if they are transmogged to something else, but when I go back to my Cenarion Spaulders xmog, they become invisible again. I know this is minor, but it does actually matter to me, so I was hoping there might be something I can do to get it working again. Additionally, last night I cleared HoF normal for the first time. The raid progression area at the bottom of my armory doesn't show that I have completed it (says I haven't downed Shek'zeer). Again, I know it's minor, but it would be sweet if I could somehow get that little green bar down there. :)Nilluh13 Apr 3, 2013
Apr 3, 2013 How do I get rid of the stupid blue crab? What the thread title says. How do I get rid of this stupid thing? It's freaking annoying; driving me away from the site.Tiario7 Apr 3, 2013
Apr 3, 2013 "Remember this computer" isn't For the last week or two, I've had to log in fully to the forums almost every day (including authenticator) despite having the "remember this computer box" checked.Fahzhi0 Apr 3, 2013
Apr 2, 2013 Chat Box My chatbox wont allow me to set up any private chat tabs nor will it allow me to even click in the box. Its just non responsive. What should I do to fix this issue. Its annoying and any help is better than none at all. ThanksTuchanka2 Apr 2, 2013
Apr 2, 2013 Brawler's and Tiller's armory reputation I've noticed that rep with the brawler's guild works fine in your in-game reputation menu, but when you go to view it in your online wowarmory it doesn't scale the same, instead it's using the old neutral - exalted ranking. For instance, I finally made rank 8 with the Brawlers and in my rep tab and when I talk to the guards I'm maxed out, but when I look on wowarmory I'm stuck at 4000/6000 friendly. Another reputation issue I found was the individuals at the Tillers. Once you get best friends with them you'll be taken from friends max to best friends max right away and in your in-game reputation tab and when you talk to that individual it will show you as maxed out, but when you look on wowarmory you will be best friends but not maxed. You can still max it out on wowarmory by doing more dailies with them, you just can not track it in game, only on wowarmory.Chainheart1 Apr 2, 2013
Apr 2, 2013 wowreforge profile not working my profile is not loading on wowreforge.com profile #5477637 error message - Failed to update profile #5477637. Message: Failed to update character Ellipses. The INSERT statement conflicted with the FOREIGN KEY constraint "FK_Items_BattleNetSuffixesMap". The conflict occurred in database "SQL2008_702944_beta", table "dbo.BattleNetSuffixesMap", column 'BattleNetId'. The statement has been terminated. Please try again later. I talked to some people who are smarter than me, and they think it may be a problem from battle.net side, and not wowreforge. I have placed a bug report with them as well, however. From battle.net armory side, if there is a problem, could it please be addressed? thanks!Ellipses0 Apr 2, 2013
Apr 2, 2013 Iphone account access When I log into battlenet from my iphone 4s I can get to the account summary page, but where the games are listed next to + signs I cannot access. It appears briefly as the page loads, but after, no matter how I click on the +, it will not expand/drop down.Firazin1 Apr 2, 2013
Apr 2, 2013 Deleted Chars Still Appear in Profile Hello! Some time ago I had two accounts. I had characters on both accounts (JMTENET and JMTENET211). I only use the JMTENET211 account now. However, when I log into Battle.net, I see remnants of characters that no longer exist from an account I no longer use. This is somewhat of a nuisance as I wish to see only the characters I presently possess or use on my JMTENET211 account. I would like these remnants to be removed. I have asked about this in the past...and I was given some lengthy reply that made very little sense. These characters no longer exist...and yet they show up in my profile and it is VERY confusing. I haven't used these characters on this account for over three years. Please tell me there is something I can do. The characters that should show up in my profile are: Nairomi (DK), Natomi, and Nocturna. The characters (remnants of deleted characters on an inactive account) that should not are: Slashdotcom, Nairomi (Shaman). Please tell me how I can get these names to no longer appear. It is quite an eye-sore.Nairomi2 Apr 2, 2013
Apr 2, 2013 Enchant display localization issue - PT-BR Hi. I'm posting in the English forums since the localized forums don't have a specific board for this. In Armory character display, advanced setting, the green enchant text that appears below the items' names show the wrong text. For instance: instead of displaying "Windsong" (Cantéolo), it displays "Weapon" (Arma). Same for Boots, Gloves, Wrist, Chest and Cloak.Projetista0 Apr 2, 2013
Apr 1, 2013 "Search My Posts" doesn't show my alts Howdy! I use various of my alts for forum posting, mostly for flavor reasons. My hunter posts my hunter bugs, for example. However, this makes hunting down my posts a giant pain, since the search feature on the forums is character specific. This usually results in my not noticing replies to posts I made on seldom-used alts.Arrataz0 Apr 1, 2013
Apr 1, 2013 Armory Shows 0.0% Expertise Reposted from bug report forum: The armory shows me as 0.0% expertise until you mouse over it, at which point it shows my total.Arrataz2 Apr 1, 2013
Apr 1, 2013 Get rid of this useless crab Yeah thanks for the laughs, but it's not funny any more. I just want to post on the forums but this stupid thing keeps getting in the way. Also, every time I click on the box where text goes for forum posts it keeps making this WHOOP sound. Crabby, thanks for coming out. No one will miss you. inb4 L2BuybettercompShoppingcart1 Apr 1, 2013
Mar 31, 2013 Need help transfering Trying to character transfer and faction change one of my toons and when i get to my payment page i can't see any of the boxes to fill out the info, please help, ty.Colfangg0 Mar 31, 2013
Mar 31, 2013 EotS Wins in RBGs are showing as Losses. Well, the title is self explanatory. Check every armory, 99.9% of Eye of the Storm games played are recorded as losses, even if you win. This has been going on for a while, I'm surprised it hasn't been fixed so I'm bringing it here.Cøøkiez4 Mar 31, 2013
Mar 31, 2013 Armory RBG record Bug 0-37 on EotS?!?! My eye of the storm record shows 0-37. I have no idea what my actual record is but I do know that my win:loss is closer to to 50:50 as I have even 1600-0 in Eye. Not a huge deal, but if people are checking my armory to determine if I am qualified for rbgs for their group one night, they might hesititate if they think I am bad luck charm for EotS. Wondering if anyone else is experiencing the same problem as well.Papajohnny2 Mar 31, 2013