Internal Error in Blizzard Updater

Technical Support
I keep getting this message at the PTR Launcher when it says it is downloading updated tools: Blizzard Updater Failed with an internal error. Please contact Blizzard Technical Supprt. I am clueless about what to do to fix it. I can't find any stickies about it, or any solutions posted by other players. Anyone have even a slight idea of what to do about this?

Here's a pic of the error message: http://img842.imageshack.us/i/blizzarderror.jpg/
This is typically caused by another program interfering.

Try patching PTR in Safemode with Networking: http://us.blizzard.com/support/article.xml?articleId=21148
________________________________________________
Account and Technical Services || I am available 6:45AM-3:45PM Pacific
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RZRWLCB < Show me you love me!
The word lethologica describes the state of not being able to remember the word you want.
Ok, I'll try this. Thanks for the reply
I tried this, and the exact same thing happened. : /
Hello Zawami,

What security software do you have? Some may still interfere even in safemode.

I would also like for you to try some permissions fixes, in case this is caused by permissions issues.

Make sure that you are on the administrative account for the computer, and if you are on Windows Vista or Windows 7 try right-clicking on the shortcut and running as administrator instead of double-clicking.

If that does not work, you can also try to take ownership of the entire World of Warcraft folder, which can sometimes fix this.

How to take ownership in Vista/7: http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/

How to take ownership in XP: http://support.microsoft.com/kb/308421
________________________________________________
Account and Technical Services || I am available 6:45AM-3:45PM Pacific
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RZRWLCB < Show me you love me!
The word lethologica describes the state of not being able to remember the word you want.
I am currently using Norton Internet Security version 18.1.0.37 (Newest) and I've already tried running as an administrator. Ok, I downloaded the take ownership thing and applied it to my whole World of Warcraft PTR folder, but still got the same message from the updater.

Any other ideas for a workaround Jessicalu? never had any problems with the PTR before this.
Um... kind of feeling left in the dark and abandoned here haha. Should I just not count on another reply and give up on this?
Bump, any more help at all please?
I would suggest that at this point, you try temporarily uninstalling Norton using the Norton Removal Tool (http://us.norton.com/support/kb/web_view.jsp?wv_type=public_web&docurl=20080710133834EN&ln=en_US)

Norton continues to run in the background even when you disable it, so it is possible that is the cause.
________________________________________________
Account and Technical Services || I am available 6:45AM-3:45PM Pacific
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RZRWLCB < Show me you love me!
The word lethologica describes the state of not being able to remember the word you want.
I tried the above and I still get the same error message. I also tried a selective startup as well.
Technically we do not support the PTR, so since we have already tried the steps that normally correct this on the release version of the game, it is possible that there is a different cause for this when it occurs on the PTR.

I would recommend that you post on the PTR forums for additional aid.
________________________________________________
Account and Technical Services || I am available 6:45AM-3:45PM Pacific
Can't find a resolution on the forums, contact a Support Rep directly: http://us.blizzard.com/en-us/company/about/contact.html
http://www.surveymk.com/s/RZRWLCB < Show me you love me!
The word lethologica describes the state of not being able to remember the word you want.
Well thanks anyways Jessicalu, but I have made some progress myself. I deleted the TEMP file from the WoW PTR folder and that made the bar progress about halfway until the error message popped up when it normall gets to the second "d" in downloading.
Hey Zawani did you get yours working because if so do you mind helping me out. Just spent $60 on Cata and now i cant even play it. Thanks Blizzard -.-"
im getting the same message......i dont know what the eff is going on or how to fix this...and its impossible to get tech support on the phone....im paying for this monthly and i cant even play!!!....i would love someone to contact me to troubleshoot this asap!....786-925-4734..thanks blizzard.
no answer???
I'm having the exact same problem and nothing is working from the suggestions up above.

It would be nice to play after spending money on the expansion...
I figured out a solution on my own after searching the internet without any luck. Here's what I did:



1) I manually downloaded the patch from the wowwiki mirror site. I needed to go from 4.0.3.13287 to 4.0.3.13329 (it's the top one). http://www.wowwiki.com/Patch_mirrors



2) I unzipped the MPQ file onto my desktop



3) I renamed the MPQ file wow-13287-13329-Win-final



4) I replaced the MPQ file wow-13287-13329-Win-final in the "Updates" folder in the wow directory with the one I renamed on my desktop.



Hopefully it works for you guys, too.
im having the internal error on my mac 10.5.8, zalanthas ur talking about ptr right????

Join the Conversation

Return to Forum