Missing Character on Mobile App and Armory

Mobile Bug Report
I have posted on quite a few other threads related to this problem, and have not yet received any assistance, so I am opening a new thread in hopes that my issue will get noticed easier.

My issue began a few months ago, around the end of September is when I noticed it. My character was not viewable under the mobile app or under the wow armory web page. I saw a few posts that stated that it would take some time to fix and that creating a ticket would not help that I would either have to wait it out or get help on the forums. I decided to wait.

Months later now, I have been logging on with this character every day doing dailies. I have earned different gear on him. I noticed one day that my guild I created wasn't accessible via the mobile app either, so I was thinking it might be causing it, so I passed Guild Ownership to another member, and /gquit. Remarkably, I was able to see the guild on the mobile app now. Playing without the mount speed increase from the guild sucked, so I decided to join a new guild. Now I still cannot find him on either the Armory or the App, but now I can't even view the new guild I am in. It appears he is breaking the guild he is in as well.

As I stated I log in to him everyday, so it has been much longer then 24 hours wait period, as I see soooo many posts from blues telling us to try again in 24 hours. I understand that there has been many similar issues with the server merges, but my server has yet to be merged so I don't believe this to be the issue. All of my other characters do get updates, and are fully accessible from the App and the Armory. I went to askmrrobot.com and THEY ARE able to pull his updated gear and stats, presumably through wow's armory APIs. Please I beg for help on this issue, as he is my most played toon at this point in time, and would really like to be able to access him from these tools you have provided us with. His information is as follows:

Realm: Velen
Name: Pzycho
Class: Warrior
Race: Human
Level: 90

Thank you in advance for your attention to this issue. I see many blue posts trying to help out here and sincerely hope that one picks up this thread and helps me troubleshoot this issue to resolution.

EDIT: Forgot to mention that I have not renamed, moved servers, switched races/factions, or any other paid service recently. He was a server move YEARS ago. I can not think of an event that this would be relateded to.

EDIT #2: Went to show my friend my warrior on askmrrobot.com. Now it shows that it can not load this character, but he is updated as of 12-14-2013, well after my problem started, so this is a new development.
<Pleads for help>
Still having the same problem here. Started about 3 days ago and still jacked up.
it's been going on for over a week now, i don't see it getting fully resolved till all the servers merge. it might be the cause, it's the only major change happening that's known to us
Server merge yesterday, played and logged off with Pzycho, still not showing up. Additionally now all my toons are shadows.
My Character is Darrowmere, Cymbidium, Orc Warrior. I am having the same trouble as none of characters are accessible either through the app or the armory website. It says :

Error the character is temporarily unavailable while it is undergoing a process such as a realm transfer or a faction change. Please try again later.

the Website says:
This character profile could not be displayed, possibly for one of the following reasons:

The character has been inactive for an extended period of time.
The character name or realm was spelled incorrectly.
The profile is temporarily unavailable while the character is in the midst of a process such as a realm transfer or faction change.
Characters that have been deleted are no longer available.

It began after the maintainence a few days ago.
I depend on the app for the aution house. It's my livelyhood. (sigh)
I hope its resolved soon.
Seems to be linked to the connected realms cause we are getting the error:

Oops
Character Not Available

This character profile could not be displayed, possibly for one of the following reasons:

The character has been inactive for an extended period of time.
The character name or realm was spelled incorrectly.
The profile is temporarily unavailable while the character is in the midst of a process such as a realm transfer or faction change.
Characters that have been deleted are no longer available.

BLIZZARD PLEASE FIX THIS... I NEED MY MOBILE AUCTION HOUSE NOW!
1 MORE DAY DOWN & BLIZZARD HAS DONE NOTHING
Would just like to update this with the fact that there have been no changes to my issues. I continue to play Pzycho everyday and he is still missing. I see so many blue posts around this forum, but none on my thread. Can I please just get an acknowledgement that yes there is an issue, we are looking into it, and you, Pzycho, are on the list to be looked at?
Same issue here on all toons in Darrowmere - they are all shadows on the armory - which also makes my WOW Legendary mouse obsolete - HELP!
Been having this issue for a couple weeks now, I think. Both in the mobile app and logging in on a desktop. Has anyone seen/heard ANY updates on this from Blizz? Are they at least aware of the issue?
Another update stating the same thing. The issue is still ongoing, still logging into this character everyday, still no word or acknowledgement from Blizzard. Is this seriously the only way I can complain about this? If I could at least put in a ticket at least I would feel like someone has seen my problem, but posting on a forum seems like a shot in the dark, especially when your thread is pushing a month in age and no blue posts have been made. All I want is for someone from Blizzard to say that they see that I am having an issue, and they are looking into it.

I can't help but be a little frustrated at this point. It took a bit of frustration to even get me to post, I don't post often, but now I am at a whole new level.
Still an issue, still logging on everyday, still no blue post.
Bump, same status, can I please get a response from blizzard?
Same problem here. None of my Norgannon characters show up. All I can see is my low level blood elf from The Underbog. It seems to be intermittent because I was able to see them yesterday. Today it is not working at all.
Ok so I had this problem aswell...it fixed itself for 2 days and now it's doing it again. Can we please get a blue post?
Similar thing is happening to my tauren paladin, also on Darrowmere, but it's been for about a month now not showing up. Accepted it because it may have been armory mobile issues, or the fact i'd been off for months on end, but this is ridiculous; i put 15 million experience on him, and re geared everything i have but my mace, and can't even see him, or remotely manage my auctionhouse anymore.

Blizz give us all a bone here?
having the same issue, can only view first 10 characters with realms starting with the letters A, B and D

Please fix this!
Yet another bump stating the same thing..

I have made 2 Sky Golems with Pzycho since this has initially happened, and am closing in on my 3rd. The problem existed before I learned the pattern.. Just saying, I have been logging in everyday with him to make the Energy Sources...

This post has been up for over a month now, my problem has been here for 3 or 4 times that. May I pretty please, with a cherry on top and extra sprinkles, get a blue post just stating, yep, we hear you, nothing we can do about it, we are working on it?

That's all I really want at this point, so I can stop logging into the forums to make sure this stays relevant and even has a chance to be seen.

Thanks!!

Edited to improve visibility to my plea.
Same issue, they all just went bye bye

Join the Conversation

Return to Forum