4.03a not downloading?

General Discussion
So, I login to wow, says I need a patch, reboot to the launcher, and no patch downloads.

Anyone else getting this?
Edit: Sorry misread the post. Yep, i get the same thing. I guess the final piece of the patch isn't ready just yet.
Head on over to the tech support area, here you will just be trolled!
dang, cant u just wait a bit. slow down, go out side, . there is life outside of WoW.


What? Since when?
Select "Show Launcher".

Exit WoW.

Click WoW Icon.

There you go.

NM, that didn't work...
dang, cant u just wait a bit. slow down, go out side, . there is life outside of WoW.


NO MUST PLAY. (and by play I mean get the download started before I head out today.)
dang, cant u just wait a bit. slow down, go out side, . there is life outside of WoW.


Wasn't aware there was a lot to do outside at 5 AM. hahaha
I get this same message, but maybe it's because I've already pre-ordered and downloaded Cata? When I restart, the launcher comes up with the green bar full. So the data is already present on my computer? Would it work that way?

Thanks!
dang, cant u just wait a bit. slow down, go out side, . there is life outside of WoW.


NO MUST PLAY. (and by play I mean get the download started before I head out today.)


This.
mine didn't dl today...but that's because apparently the background dl'er was shneaky....ftw
I get this same message, but maybe it's because I've already pre-ordered and downloaded Cata? When I restart, the launcher comes up with the green bar full. So the data is already present on my computer? Would it work that way?

Thanks!


I'm believing this in order to forestall crushing disappointment.
From what little data I have (we haven't had the new launcher very long), patch data seems to come to us much later in the maintenance cycle than it used to. You may not wish to wait for it.
Maybe it's because the patch will not be available until the "extended maintenance" is complete.
Unfortunately I have not done the digital download of cata. Also the installer on the launcher should probably run even if it was 'pre downloaded'.

I'm sure the poster above is correct instating that they probably just don't have the second half of the patch process enabled yet.

(Considering Blizzard tech is in California only, If it was a mistake, they probably won't know about it until noon. If it's just the 24 tech guys are being a tad slow, it'll probably be up any minute.)
dang, cant u just wait a bit. slow down, go out side, . there is life outside of WoW.


what is this 'out side' you speak of?
dang, cant u just wait a bit. slow down, go out side, . there is life outside of WoW.


what is this 'out side' you speak of?


I think he's talking about Nagrand maybe.
dang, cant u just wait a bit. slow down, go out side, . there is life outside of WoW.


what is this 'out side' you speak of?


It is a vile, baseless rumour. Do not believe it!
its a 5mb patch.... with 5 hours to go ... i think you'll live

Join the Conversation

Return to Forum