[Bug] Elementium Stormshield - Display

Bug Report
1 2 3 13 Next
Item: Elementium Stormshield

Problem: Not displaying on back of character when sheathed.

Was reported by Pravada (in my guild) after purchase/crafted.

Is this intentional?
It cant be... I hope... I hate the look of my pally with no shield on her back...

fix pl0x!
Seriously. Please fix!
Just made it and was hoping they fixed it... nope. X(

Bump for an awesome looking shield that should be on my back!
Bump! I don't think this is intended, the shield is cool looking, I need to have it on my back!
Made mine today and was sad. I look like a druid with no shield.
its pretty, i want to see it, esp after paying 8k for it
Also having this problem .. it's been posted many times before.

All races.
This should be top priority.
Hoping for a fix!
Shield matches perfectly with Shaman t11... too bad I can't see it =[

(Surely the hampsters spinning the illustrious Bug Fix wheel can work a wee bit harder to produce results!)

Apparently a known issue. But I was disappointing to see that yet again it has been ignored in the hotfix notes up on mmo-champ.
Hoping for a fix during this restart....
They dont fixed it :S
Hidden sheathed shield makes me a sad panda :(

fix this please!
I spent so many golds, please I want to look at my new sexy shield!
Another round of hotfixes and not even a mention... if it can't be hotfixed that's fine, but could we at least get a timetable for when one of the best caster shields in the game will have a graphic? Please and TY

Join the Conversation

Return to Forum