*HUNTER* Aspect Dancing Question

UI and Macro
Ok so say i have this basic macro set-up

#showtooltip <insert>
/cast !Aspect of the hawk
/cast Arcane Shot

When im using arcane shot it cont. spams aspect of the hawk ofc.
I was wondering if there was any known ways to make it to where if AoH is already up it dosent cast it. Only if my aspect of the fox is up or a different aspect.

Thanks in advance.
No way to do this. Macros can't cast based on presence/absence of buffs/debuffs.
Thanks.
My question probably belongs in the Hunter forms, but do you find that this actually increases your DPS? Just wondering, because I have a pretty geared hunter, but I haven't taken the time to create all the macros for my shots.

If you are still watching this thread, let me know if you could :)
Yeah, whenever im using Arcane shots (basicly spamming because im BM) im always in Eagle, But whenever i run outta focus i use

#showtooltip
/cast rapid fire
/cast aspect of the fox
/cobra shot (or steady shot)

I just prefer cobra shot (+duration of ss) to the extra 200 dmg of steady shot
Just remember that if you add ! infront of any aspect it will make it STAY on if you spam it instead of turning on and off
It can be done using bar swaps to keep track of which aspect is up, which works with the default actionbar, but may not work with actionbar replacement mods. It also means that *every* shot which favors a particular aspect must be macro'd this way:

#showtooltip Arcane Shot
/cast [noactionbar:1] !Aspect of the Hawk
/changeactionbar 1
/cast [actionbar:1] Arcane Shot

#showtooltip Steady Shot
/cast [noactionbar:2] !Aspect of the Fox
/changeactionbar 2
/cast [actionbar:2] Steady Shot
Wow this works amazingly well!!! Sayuri, what are you doing later this afternoon? <3!

It can be done using bar swaps to keep track of which aspect is up, which works with the default actionbar, but may not work with actionbar replacement mods. It also means that *every* shot which favors a particular aspect must be macro'd this way:

#showtooltip Arcane Shot
/cast [noactionbar:1] !Aspect of the Hawk
/changeactionbar 1
/cast [actionbar:1] Arcane Shot

#showtooltip Steady Shot
/cast [noactionbar:2] !Aspect of the Fox
/changeactionbar 2
/cast [actionbar:2] Steady Shot
It can be done using bar swaps to keep track of which aspect is up, which works with the default actionbar, but may not work with actionbar replacement mods. It also means that *every* shot which favors a particular aspect must be macro'd this way:

#showtooltip Arcane Shot
/cast [noactionbar:1] !Aspect of the Hawk
/changeactionbar 1
/cast [actionbar:1] Arcane Shot

#showtooltip Steady Shot
/cast [noactionbar:2] !Aspect of the Fox
/changeactionbar 2
/cast [actionbar:2] Steady Shot


This! This is the greatest solution ever.

I was just wanting to add something. In PVE I don't want to automatically switch over to Fox every time I cast Cobra. If I have the opportunity to stand still and get a Cobra off it would be more beneficial to stay in Hawk.

So what I did, instead of tying Fox into a Cobra macro I created a separate macro for switching into Fox. It's basically:

/cast !Aspect of the Fox
/changeactionbar 2

This way, I only enter Fox when I need too and it also switches back to the action bar with Hawk macroed in, so everything still works the same. I've been finding this extremely helpful.

Again, thanks for the tip!
Hello!

Very smart this Macro, thank you for sharing!

I´m having just a little problem... Using the addon Dominos this macro doesn´t work, so i had to disable it... do you know if i can make it work with my addon?
Loving this concept of two different bars for aspects, seems to work wonders preventing aspect spam and making everything smoother.

I'm having one glaring problem however, and thats with spell queueing. If you are shooting Cobra Shots in aspect of the fox, and say hit your kill command macro half way through the cast, it will of course queue the kill command to cast as soon as possible, like normal, and switch back to bar 1. However, it will NOT queue the aspect switch, and thus you are switched back to bar 1 still in fox and the whole system breaks down.

Anyone know a fix to this?
I've been having the same problem, maybe put /stop casting, I haven't tried that out yet

Join the Conversation

Return to Forum