Mobile armory won't connect

Mobile Bug Report
I cannot get logged into mobile armory. The connection either times out, or I get a message that it cannot establish a connection to the server. I'm tried both via wifi and 3g, and get the same message. My fiance is having the same problem with his mobile armory connection on his phone, as well.
I too am having this issue on wifi and 3G. Jalad is not alone.
I am also having this problem.
Same. I have more than one account and have tried with two different ones. Different servers, but with the same result.

I'm using the iPhone version and it's been problem free until today.
I'm having this problem as well. I cannot log into the mobile app at all, the error I get is "Connection Error unable to establish a connection to the server"

I've tried deleting and reinstalling the app, rebooting my phone, etc. Nothing is working.
same here as above, using android app
Iphone app hasn't been working all day..... =[
I'm also having this problem. I'm using the droid app.
So we all have same issue... Is there a solution/workaround before I lose all my sweet bids
;~{.

Mo
Same problem here
Same issue on 3g mobile network
i'm havin it too
Call out thy ITs
I am having the same problem with my iphone 4 on 3g and Wifi.
Same problem here. iPhone 4, also tried on both 3G and WiFi.
Same issue for at least the last several hours here.
Only just got this app and started paying now it's not even letting me connect to the US realms but it has no dramas with Korea & Europe wtf !?
Same issue via iPhone app all day on both 3G and Wi-Fi.

"Connection Error. If you are connecting via Wi-Fi, the access point you are connecting to may be blocking port 8780."

or

"Login Failed - Unable to establish connection to server."
Yep, same problem here but I checked logging in to European servers and I CAN log in there. I have no accounts but I have access. Seems the connections to americas servers are down. Even though I have access to armory info through safari. So it's a mobile app issue, I think.
Good to know I'm not the only one.

Join the Conversation

Return to Forum