My left and right click buttons do not work!

UI and Macro
i was tinkering with this:

"I was playing around and found a solution to do this that worked very well. The only compromise you have to make is to have Shift + Right Click to wand something leaving Right Click as the interact button (this could be reversed if wanted).

What I did was create a macro and called it "Wand", you can name it whatever you want but make sure to use the right name of your macro later on. The macro contents are as follows,

/target mouseover

/cast Shoot

It is not wise to use "/cast [target=mouseover] Shoot" because this lead to undesired results, namely after the mouseover was killed, it tried to wand your current target and that could be bad. So I made the macro change your target to prevent unintentional wanding.

Now to call this macro on the button click, type the following code into your chat box and hit enter.

/script SetBindingMacro("SHIFT-BUTTON2", "Wand"); SaveBindings(GetCurrentBindingSet());

Alternatively if you want to wand on Right Click and interact with Shift + Right Click, type the following code in and hit enter.

/script SetBindingMacro("BUTTON2", "Wand"); SetBinding("SHIFT-BUTTON2","TURNORACTION"); SaveBindings(GetCurrentBindingSet());

You can also have any other combination of Shift, Alt, and/or Ctrl that you want, just change the above code.

Please try this out and see if it suits your needs. If you have any problems, I will be glad to try to solve them."


this was on WoWhead.

i was tinkering with it and realized that my shift+right click no longer auto-loots. so i changed

/script SetBindingMacro("BUTTON2", "Wand"); SetBinding("SHIFT-BUTTON2","TURNORACTION"); SaveBindings(GetCurrentBindingSet());

to

/script SetBindingMacro("BUTTON1", "Wand"); SetBinding("SHIFT-BUTTON2","TURNORACTION"); SaveBindings(GetCurrentBindingSet());

that's all i remember, but i did a couple other things as well that i can't seem to recall. at first it was just my right click that stopped working, then my left click lost functionality as well.

i CAN click abilities and navigate the WoW Menu and interface just fine. my mouseover does change to the sword when i hover over a mob and whatnot, it even displays the mob's name and etc.

here's a list of what i can't do:
loot,
attack,
target,
steer (with the right click + drag function)
etc.,

pretty much ,my left click and right click dont work at all anywhere on WoW outside of the interface.


help please!
bump?
Have you tried deleting the macro in question?
06/12/2011 03:10 PMPosted by Atonement
SetBinding("SHIFT-BUTTON2","TURNORACTION");


With this code, your changed the TURNORACTION to be shift- rightclick and not just right click, so in order to loot, attack and steer, you would need to hold down the shift button, too.

If that is not the problem, then

/script SetBindingMacro("BUTTON1", "Wand")


feels a little suspect to me, as you made your left mouse button change to your wand macro. I'm not certain about this, but WoW may see this as a remaping of what the left mouse button is supposed to do and remove its old bindings that would let you target, and if thats the case, you'd have to look up what that old function is and rebind the BUTTON1 to it.
It's not a good idea to directly rebind your left and right click if you don't exactly know what you're doing.

to restore the default functions of left and right click, run this script;

/run SetBinding("BUTTON1","CAMERAORSELECTORMOVE")SetBinding("BUTTON2","TURNORACTION")SaveBindings(GetCurrentBindingSet())
It's not a good idea to directly rebind your left and right click if you don't exactly know what you're doing.

to restore the default functions of left and right click, run this script;

/run SetBinding("BUTTON1","CAMERAORSELECTORMOVE")SetBinding("BUTTON2","TURNORACTION")SaveBindings(GetCurrentBindingSet())


Where do I run this? Having some what the same problem, would just like to restore "Move and Steer" to simultaneously clicking both mouse buttons :(
02/08/2013 07:35 PMPosted by Lilposer
Where do I run this? Having some what the same problem, would just like to restore "Move and Steer" to simultaneously clicking both mouse buttons :(

Just copy it, open your chat editbox with enter, paste it with Ctrl-V and press enter.
02/08/2013 07:46 PMPosted by Choonster
Where do I run this? Having some what the same problem, would just like to restore "Move and Steer" to simultaneously clicking both mouse buttons :(

Just copy it, open your chat editbox with enter, paste it with Ctrl-V and press enter.


I did exactly that, nothing happened though, binding was still the same :S

Join the Conversation

Return to Forum