How to turn off auto-attack?

UI and Macro
Whenever I shadowstep, I auto-attack the target in the back, and usually have to vanish and try again :@.

Help?
/cast Shadowstep
/stopattack
But when you hover of autoattack in your spellbook, it says this ability can be toggled on and off.
using the macro command /stopattack will stop you from auto-attacking until you either;
-start attacking by right clicking
-click the Auto Attack button
-use the macro command /startattack
-use another skill that turns on auto-attack (Sinister Strike, for example).
Are you right clicking on the mob before activating Shadowstep? If you are, that would be what is causing you to auto-attack after Shadowstepping. Don't right click the mob, left click it.
That's not what he is asking. He's talking about the auto attack found in the general tab of the spellbook. when you hover the mouse over it, it says at the very bottom "this ability can be toggled on or off" and I too would like to know where that toggle is located as well :)
Well if you press it and start attacking a target, you can press it again and you'll stop attacking.
12/15/2011 10:09 PMPosted by Zaros
That's not what he is asking. He's talking about the auto attack found in the general tab of the spellbook. when you hover the mouse over it, it says at the very bottom "this ability can be toggled on or off" and I too would like to know where that toggle is located as well :)


You drag Auto Attack to your action bars, and then hit it to turn auto attack on and off.
Seems retarded to have it state ability to turn on/off when it has to be done each time. I want it PERMANENTLY OFF
Holy necro batman...

Join the Conversation

Return to Forum