Repeating Sent Messages

UI and Macro
Hello UI and Macro forum. I recently have encountered a problem since Patch 4.2. It's difficult to explain, but please bear with me.

Say you want to advertise in trade for anything, whether it be a PuG, raid, event, buying or selling items, or professions. Well, most of us know of a nifty keypress that allows us the game automatically retype our previous sent messages- starting with our most recently sent one- using the "Alt-down/up" or "control-down/up" keypresses.

However, since patch 4.2, I've run into a problem. The UI seems to "skip" my most recent sent message and go to the second most recent message sent. Hard to understand? Imagine this [skip if you know what I mean]:

- Log in.

- I type in /s, "Hello, world"

Then,

-I whisper a friend "sup"

Next,

- I type in /gchat "hey fellas"

I decide to form a PuG.

-I say in trade "LFM BH"

Now I don't want to keep typing in "LFM BH" over and over, so I press alt-down. However, instead of the desired "LFM BH" popping up, since it was my most recently sent message, I get "hey fellas" in /gchat. By pressing down or up more(holding alt), i can scroll through "hello, world!", "sup", and "hey fellas", but my "LFM BH" is simply not on the list.

-I decide to type in "/who baradin hold".

I press alt-down again.

Hey, look! Instead of "/who baradin hold", i get "LFM BH". I can cycle through my sent messages, but "/who baradin hold" isn't there in the list. I press enter to send "LFM BH" again.

I alt-down again, and guess what. "LFM BH" is not on the list.

Do you see what I'm trying to say?

This process continues, where eventually all of the messages get mixed up order-wise and I find it difficult to advertise/ repeat anything in World of Warcraft. I PuG alot so this tool is useful to me, but now that I am having trouble it's hard to get a group together, especially on my main's server where trade is zipping by fast.

I have tried:

Deleting Interface, Cache, and WTF folders and launching the game.
Disabling all add-ons.
Running launcher to see if something hadn't downloaded.

What is even more weird is that on my laptop I can use this keypress perfectly, which leads me to think that it's something with my computer, or how something was installed.

Thanks for reading.
Any help on this would be greatly appreciated.
Generally with a problem of this sort you'd want to wait longer than an hour before bumping your post, especially considering how little traffic this forum is getting tonight ;)

Unfortunately, I have no solution to your problem. It definately sounds like a computer problem and not something related to WoW. Have you tested this in other programs?
Generally with a problem of this sort you'd want to wait longer than an hour before bumping your post, especially considering how little traffic this forum is getting tonight ;)

Unfortunately, I have no solution to your problem. It definately sounds like a computer problem and not something related to WoW. Have you tested this in other programs?


Can you define other programs, and how I would test it ?
This may sound silly, but have you tried alt-up? I believe alt-up and alt-down scroll in opposite directions through your messages.
Generally with a problem of this sort you'd want to wait longer than an hour before bumping your post, especially considering how little traffic this forum is getting tonight ;)

Unfortunately, I have no solution to your problem. It definately sounds like a computer problem and not something related to WoW. Have you tested this in other programs?


Can you define other programs, and how I would test it ?


Other MMOs.
07/12/2011 08:19 PMPosted by Choonster
This may sound silly, but have you tried alt-up? I believe alt-up and alt-down scroll in opposite directions through your messages.


I have tried both ways, however it still will not show my most recently sent message.



Can you define other programs, and how I would test it ?


Other MMOs.


I don't play any other MMOs; I also play on a Mac if that changes anything.
I am having the same problem.
I am on Mac OS X 10.6.8, 2011 macbook pro.
Everyone has this problem. The chat history often loses previous messages for no obvious reason.

Though I'm old school and scroll through with Ctrl-P (previous) and Ctrl-N (next).
it probly doesnt do say / Commands or chat channles like trade an such, so spammers couldnt use it to be annoying. SoOoO GG :D
07/12/2011 08:19 PMPosted by Choonster
This may sound silly, but have you tried alt-up? I believe alt-up and alt-down scroll in opposite directions through your messages.
This is correct. The behavior is very similar to up-arrow in the cmd.exe window or in a Unix bash shell.
I'm sure it's highly relevant to the original poster after over a year.
I cant send any messages at all. It appears on screen in the chat bubble... but not in the Chat bar.
I cant send any messages at all. It appears on screen in the chat bubble... but not in the Chat bar.


Necroing (bumping really old threads) is against the Forum code of conduct, especially if your problem has nothing to do with the original post.

If you're not sure, it's always better to create a new thread.

Join the Conversation

Return to Forum