Launcher "Internal Error"

Technical Support
When I tried to start up my launcher, it says "Downloading Update Tools". It then just abruptly stops.

It then said "Blizzard Updater failed with an internal error, please contact technical support."

Is this just me, or do other people have it and how do I fix it?
Yea I am unable to download the patch when I start the launcher
I just got started updating mine and it seems to be working
Interesting error.

Have you tried running the launcher as admin ?

If that doesn't work can you post your launcher.log , connection.log and downloader.log ?
________________________________________________
Bringing you walls of text and cookies since 2005 :)

Mac Tech Support MVP (moonlights in other forums)
Here to Help :)
Sadly running it through admin didnt work, I dont know how to post my launcher/connection/downloader log =L
The updater is trying to install a corrupt patch. You have to either delete the Updates folder (World of Warcraft\Updates) or delete the patch which is in that folder (wow-0-14545-Win-final.MPQ)
08/30/2011 10:56 AMPosted by Cartiour
Sadly running it through admin didnt work, I dont know how to post my launcher/connection/downloader log =L


Should be small enough to get it on a pastebin at pastebin.com

EDIT : Try what Barthus suggests. His patching system knowledge is vaster then mine.

________________________________________________
Bringing you walls of text and cookies since 2005 :)

Mac Tech Support MVP (moonlights in other forums)
Here to Help :)
08/30/2011 10:59 AMPosted by Bluspacecow
Sadly running it through admin didnt work, I dont know how to post my launcher/connection/downloader log =L


Should be small enough to get it on a pastebin at pastebin.com

EDIT : Try what Barthus suggests. His patching system knowledge is vaster then mine.
But the error is probably in the blizzard updater log so you'd figure it out eventually :P
08/30/2011 10:59 AMPosted by Barthus
The updater is trying to install a corrupt patch. You have to either delete the Updates folder (World of Warcraft\Updates) or delete the patch which is in that folder (wow-0-14545-Win-final.MPQ)

Before deleting the updates folder, I looked within the folder and did not find the file you wrote down, upon looking inside the folder, I proceeded to deleting the Update folder, Reopened the launcher and had the same issue
08/30/2011 11:05 AMPosted by Cartiour
The updater is trying to install a corrupt patch. You have to either delete the Updates folder (World of Warcraft\Updates) or delete the patch which is in that folder (wow-0-14545-Win-final.MPQ)

Before deleting the updates folder, I looked within the folder and did not find the file you wrote down, upon looking inside the folder, I proceeded to deleting the Update folder, Reopened the launcher and had the same issue
Is the launcher downloading the tools patch (Updates tools) or is it displaying "Applying updates" and showing the percentage?
Problem solved.

If anyone else is having this issue, I would recommend trying this.

Go into the World of Warcraft folder (wherever that may be on your computer), and open "Repair".

Start the repair, wait for it to finish, and then open "Launcher"

Its worth a shot, I did this and now my game just finished patching.
When starting up the launcher, I see all the other crap that usually pops up with the launcher and then see the grey play buttion with no percentage bar or anything. As soon as I recieve the connection error problem, the blue bar goes up by about 7%(without shouwing percent, making an estimation) and right above it saying Downloading Updated Tools
Problem solved.

If anyone else is having this issue, I would recommend trying this.

Go into the World of Warcraft folder (wherever that may be on your computer), and open "Repair".

Start the repair, wait for it to finish, and then open "Launcher"

Its worth a shot, I did this and now my game just finished patching.
I have tried this before going to the forums to ask for help. This is what it says after pressing repair " Repairs were complete, no problem found"
08/30/2011 11:19 AMPosted by Cartiour
When starting up the launcher, I see all the other crap that usually pops up with the launcher and then see the grey play buttion with no percentage bar or anything. As soon as I recieve the connection error problem, the blue bar goes up by about 7%(without shouwing percent, making an estimation) and right above it saying Downloading Updated Tools
You can delete the temp folder (World of Warcraft\temp) and try again running the launcher as admin.

Or you can download and install the tools patch
http://www.gamefront.com/files/20726808/wow_4_2_0_2552_enUS_tools_patch_exe

#-----------------------------------------------------------
# System started at 2011-08-30 16:55:38.6605
# system: JONATHAN-PC
#-----------------------------------------------------------
16:55:38.6635 Downloader version 2.2.1.1542
16:55:40.0404 Downloader could not connect to Launcher
16:55:40.1094 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 16:56:28.3379
# system: JONATHAN-PC
#-----------------------------------------------------------
16:56:28.3387 Downloader version 2.2.1.1542
16:56:28.8762 Downloader could not connect to Launcher
16:56:28.8780 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 16:57:40.6839
# system: JONATHAN-PC
#-----------------------------------------------------------
16:57:40.6850 Downloader version 2.2.1.1542
16:57:41.2175 Downloader could not connect to Launcher
16:57:41.2194 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:03:13.8394
# system: JONATHAN-PC
#-----------------------------------------------------------
17:03:13.8407 Downloader version 2.2.1.1542
17:03:14.4221 Downloader could not connect to Launcher
17:03:14.4245 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:04:01.4254
# system: JONATHAN-PC
#-----------------------------------------------------------
17:04:01.4263 Downloader version 2.2.1.1542
17:04:01.9557 Downloader could not connect to Launcher
17:04:01.9604 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:05:14.1620
# system: JONATHAN-PC
#-----------------------------------------------------------
17:05:14.1629 Downloader version 2.2.1.1542
17:05:14.6898 Downloader could not connect to Launcher
17:05:14.6973 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:09:53.4977
# system: JONATHAN-PC
#-----------------------------------------------------------
17:09:53.4987 Downloader version 2.2.1.1542
17:09:54.0603 Downloader could not connect to Launcher
17:09:54.0633 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:16:04.7857
# system: JONATHAN-PC
#-----------------------------------------------------------
17:16:04.7878 Downloader version 2.2.1.1542
17:16:05.3220 Downloader could not connect to Launcher
17:16:05.3246 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:16:59.4973
# system: JONATHAN-PC
#-----------------------------------------------------------
17:16:59.4985 Downloader version 2.2.1.1542
17:17:00.0367 Downloader could not connect to Launcher
17:17:00.0388 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:36:15.7320
# system: JONATHAN-PC
#-----------------------------------------------------------
17:36:15.7329 Downloader version 2.2.1.1542
17:36:20.7765 Downloader could not connect to Launcher
17:36:20.8091 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:40:37.3360
# system: JONATHAN-PC
#-----------------------------------------------------------
17:40:37.3373 Downloader version 2.2.1.1542
17:40:42.3701 Downloader could not connect to Launcher
17:40:42.3775 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:54:32.6244
# system: JONATHAN-PC
#-----------------------------------------------------------
17:54:32.6266 Downloader version 2.2.1.1542
17:54:33.8126 Downloader could not connect to Launcher
17:54:33.8339 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 17:55:51.7105
# system: JONATHAN-PC
#-----------------------------------------------------------
17:55:51.7118 Downloader version 2.2.1.1542
17:55:52.5056 Downloader could not connect to Launcher
17:55:52.5131 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 18:08:53.2514
# system: JONATHAN-PC
#-----------------------------------------------------------
18:08:53.2523 Downloader version 2.2.1.1542
18:08:58.2876 Downloader could not connect to Launcher
18:08:58.3017 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 18:09:47.0202
# system: JONATHAN-PC
#-----------------------------------------------------------
18:09:47.0212 Downloader version 2.2.1.1542
18:09:47.5534 Downloader could not connect to Launcher
18:09:47.5613 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 18:16:46.0282
# system: JONATHAN-PC
#-----------------------------------------------------------
18:16:46.0291 Downloader version 2.2.1.1542
18:16:47.1540 Downloader could not connect to Launcher
18:16:47.1604 Downloader has shut down.

#-----------------------------------------------------------
# System started at 2011-08-30 18:21:23.8477
# system: JONATHAN-PC
#-----------------------------------------------------------
18:21:23.8487 Downloader version 2.2.1.1542
18:21:24.3919 Downloader could not connect to Launcher
18:21:24.4087 Downloader has shut down.


Before deleting the folder
When starting up the launcher, I see all the other crap that usually pops up with the launcher and then see the grey play buttion with no percentage bar or anything. As soon as I recieve the connection error problem, the blue bar goes up by about 7%(without shouwing percent, making an estimation) and right above it saying Downloading Updated Tools
You can delete the temp folder (World of Warcraft\temp) and try again running the launcher as admin.

Or you can download and install the tools patch
http://www.gamefront.com/files/20726808/wow-4.2.0.2552-enUS-tools-patch.exe

Downloaded it, didnt show download bar but still came up with an error.
Edit: It downloaded completely, it was when I opened the Launcher (with Admin) that it showed the errror.
Im off to my class, I will respond when I come back, informing you guys so you dont think i fixed it and didnt reply back
I thought the Launcher would be the one connecting to the Downloader not the other way around...

I'm not sure if deleting is going to help in this case, running as admin might and downloading the tools patch will bypass whatever is causing the issue for sure. (At least until the next issue)

You could also go in the temp folder and run the tools downloader from there, in this case it wouldnt have to *talk* to the launcher and should be able to finish downloading.
I thought the Launcher would be the one connecting to the Downloader not the other way around...

I'm not sure if deleting is going to help in this case, running as admin might and downloading the tools patch will bypass whatever is causing the issue for sure. (At least until the next issue)

You could also go in the temp folder and run the tools downloader from there, in this case it wouldnt have to *talk* to the launcher and should be able to finish downloading.

Did what you said got this after it finished. This update does not need to be applied. It requires a version of "Launcher.exe" older than 4.2.0.2552, but you already have version 4.2.0.2552.
Ok.. But now I dont really get why the downloader wasnt able to connect to the launcher...

Can you post the contents of the file "World of Warcraft\Logs\Blizzard Updater log.html"?

Join the Conversation

Return to Forum