My add ons do not work

New Player Help and Guides
Post Limit:
I have been unable to get any help with figuring out how to get my Add-ons to work properly. I do not know how to exactly explain what my problem is, but I downloaded a few addons and they are not working at all. So if anybody would be so kind as to help me out with that, that would be fantastic
This would be better in the UI/Macro forums, but I suspect you're just on a Starter Edition?

You'll need to tell us which add-ons you're talking about.
Well you'd have to be more specific.

Have they worked before? Then they might be outdated.

Have they never worked? You might not have installed them right. You need to drag the folders into your Interface >> addons folders. Some addons are contained within the folders they are downloaded in, so you'll have to drag their contents out into the addons folder.

Done all that? Make sure they are enabled for your character. On your character log in screen there is a button that says "addons" that shows you a list. Any unchecked or red addons are not enabled. Red means out of date, if you enable loading out of date addons they may work fine or they may produce a lot of errors so use with discretion.
see that is the problem. I downloaded the entire file. Lets just say that I was trying to get the /recount Add-on to work. I do not see a button that says "Addons" ... There are no buttons besides the Delete/create character and change realm buttons. I added all the files that I downloaded into the WTF file that is within the WoW main info folder. ... after that, i do not know.
You are supposed to put the addon files into the "Addon" folder, inside the "Interface" folder, inside your WoW folder. Not in your WTF folder.
After you downloaded the addon did you place it in the correct folder? If that's the problem and you cant figure out how to do it, try the curse client from curse.com.
I do not see a button that says "Addons" ... There are no buttons besides the Delete/create character and change realm buttons.
It would be in the lower left of the screen, so you probably just don't have it installed correctly.
09/15/2011 04:33 PMPosted by Tkatii
I do not see a button that says "Addons" ... There are no buttons besides the Delete/create character and change realm buttons.
It would be in the lower left of the screen, so you probably just don't have it installed correctly.


The button doesn't appear when there are no addons installed at all. So that's what the problem is going to be; the addons are in the wrong folder, as noted above.

There's a great sticky in the UI & Macros forum on installing addons and fixing problems like this. It's worth checking out. http://us.battle.net/wow/en/forum/topic/1536706542
09/15/2011 04:16 PMPosted by Cerylia
You are supposed to put the addon files into the "Addon" folder, inside the "Interface" folder, inside your WoW folder. Not in your WTF folder.


oh god. I feel pretty stupid. thank you for that little tidbit. I just had it in the wrong folder. I will get back to you guys at about 7 PM MST to let you know whether or not it worked.
09/15/2011 04:51 PMPosted by Akirliy
You are supposed to put the addon files into the "Addon" folder, inside the "Interface" folder, inside your WoW folder. Not in your WTF folder.


oh god. I feel pretty stupid. thank you for that little tidbit. I just had it in the wrong folder. I will get back to you guys at about 7 PM MST to let you know whether or not it worked.


Don't worry so much about it. There's a first time for every one of us. :)
Even the best computer techs sometimes forget to check if the computer is plugged in when they're trying to figure out why it won't turn on. ;]
This was a helpful post, I could not figure out how to do my AddOns, thanks for showing us all.

Join the Conversation