Are you Lagging?

Mac Technical Support
This is a consolidated thread for Tips/Tricks in troubleshooting lag issues by diagnosing various parts of your connection. It also gives you a checklist of what we might ask for when you create a thread on your own lag. Including as much of this as possible greatly improves our ability to assist you with network related issues. Even some more advanced trouble shooting steps are included such as optimizing wireless network signal. Also lists

Here is some of the information we could use:

Mac Details:
  • Hardware Overview
  • Graphics Overview
  • Software Overview
  • Network Details:
  • Modem/Router make & model
  • Internet Service Provider (ISP)
  • Your ISPs advertised speed
  • Your "Optimize Network for speed" setting
  • Realm name your issues occur
  • Are other PCs on same connection affected?
  • Network Diagnostics:
  • A network traceroute to your realm (while lagging)
  • Speed Test close to your realm (while lagging)
  • Line Quality Test (while lagging)

  • To get a trace to the realm while you're connected:
    1. Go to Mac HD => Applications => Utilities folder.
    2. Open the Network Utility program.
    3. Choose Netstat tab and leave "Display the state of all current socket connections" selected.
    4. Click "Scan."
    5. Find the first foreign address that says battlenet (not bnetgam)
    6. Copy/paste the IP address into the Traceroute tab.
    7. Command + C to copy the data resulting from the trace.
    8. In your reply, use command + V to paste the data.

    Run a Speedtest using a test server closest to your realm of play (you have to manually change server or it just uses closet one to you, which is not a good test of the speeds you may get to an actual diff state or longer mileage path. If you don't know where your realm is, post the realm you have troubles on and i'll find out for you. Mine for example is in Chicago so when i run a speedtest i use a chicago data test server even though i'm in georgia, because i'm not intested in testing my speed to atlanta, when diagnosing a connection problem to chicago, i want to test my speed to chicago to check for degridation of speed on that route.
    http://wwww.speedtest.net/

    Here is a more thorough test that does a reverse traceroute from both an east coast and a west coast test server right to your computer. This test is free once you grab a free account there (recommended anyways, super duper site for network trouble shooting, with direct ISP forum support available as well for most ISPs with authorized tier 2 techs from all ISPs ready to assist you with ISP issues. All free.
    http://www.dslreports.com/pingtest

    Wireless Diagnostics (if Applicable):
  • Tune wireless channel for less interference
  • Try a wired connection
  • Secure wireless if it's open

  • To tune wireless router channel:
    1. Download Air Radar Demo(http://www.macupdate.com/app/mac/27740/airradar)
    2. Run Air Radar, and use the scan now option
    3. Note the channel numbers all the wireless networks nearby are, including your own.
    4. You want to be on a channel as far away as anyone else as possible.
    5. Go into your router via web interface (probably 192.168.1.1 or something similar)
    6. Find the channel settings in wireless options and set it to a channel that differs from your neighbors.
    7. Rescan with Air Radar to see if signal strength improved. Retune as needed until optimal signal/low interference.
    <Reserved>
    ________________________________________________
    Mac Tech Support MVP
    Addon Author
    http://www.curseforge.com/profiles/mysticalos/
    /stickied, thanks Omegal
    ________________________________________________
    Mac Tech Support for Baaaaahlizzard Entertainment || Sunday to Thursday 11:00 am - 8:00 pm CST
    http://www.surveymk.com/s/RF8K3KG ---- Rate my Baaaaalue Posts. How's this sheep doing?
    The mechanical sheep with a heart of gold...
    If at first you don't succeed... call it Version 1.0..
    I am lagging terribly at random times, especially in arena and BGs. The game is pretty much unplayable right now.

    Netstat test:
    traceroute to 199.107.7.45 (199.107.7.45), 64 hops max, 52 byte packets
    1 10.0.1.1 (10.0.1.1) 8.739 ms 5.048 ms 14.436 ms
    2 10.75.135.1 (10.75.135.1) 32.467 ms 22.070 ms 45.309 ms
    3 ip68-4-13-149.oc.oc.cox.net (68.4.13.149) 20.230 ms 10.330 ms 12.126 ms
    4 68.4.15.250 (68.4.15.250) 15.630 ms 11.684 ms 11.415 ms
    5 ip68-4-11-10.oc.oc.cox.net (68.4.11.10) 12.624 ms 14.337 ms 12.297 ms
    6 ip68-4-11-92.oc.oc.cox.net (68.4.11.92) 12.426 ms 12.445 ms 52.595 ms
    7 langbprj01-ae1.rd.la.cox.net (68.1.1.13) 13.440 ms 21.983 ms 11.036 ms
    8 192.205.37.145 (192.205.37.145) 34.652 ms 21.188 ms 25.991 ms
    9 cr2.la2ca.ip.att.net (12.122.129.106) 108.836 ms 108.171 ms 105.006 ms
    10 cr1.slkut.ip.att.net (12.122.30.29) 101.106 ms 103.680 ms 101.638 ms
    11 cr2.dvmco.ip.att.net (12.122.30.26) 114.749 ms 90.131 ms 92.894 ms
    12 cr1.cgcil.ip.att.net (12.122.31.86) 96.514 ms 92.144 ms 87.865 ms
    13 cr1.cl2oh.ip.att.net (12.122.2.206) 112.402 ms 107.551 ms 89.753 ms
    14 cr2.cl2oh.ip.att.net (12.122.2.126) 98.267 ms 94.311 ms 87.583 ms
    15 cr2.phlpa.ip.att.net (12.122.2.210) 86.947 ms 99.228 ms 87.431 ms
    16 gar1.pitpa.ip.att.net (12.122.107.85) 95.891 ms 88.258 ms 85.035 ms
    17 12.122.251.2 (12.122.251.2) 92.536 ms 94.988 ms
    12-122-254-242.attens.net (12.122.254.242) 95.218 ms
    18 mdf001c7613r0004-gig-12-1.nyc3.attens.net (63.240.65.14) 91.888 ms
    mdf001c7613r0003-gig-10-1.nyc3.attens.net (63.240.65.10) 118.884 ms
    mdf001c7613r0004-gig-12-1.nyc3.attens.net (63.240.65.14) 112.951 ms


    Speedtest:
    Ping=27 ms
    download=10.34 Mbps
    upload=1.9 Mbps

    Earlier it was 18 Mbps download and still lagging. My Vent is choppy too.
    (have also rebooted everything, turned off addons, turned off Vent and no change).
    that's a traceroute to your modem, it doesn't show anything. can you traceroute to your realm?
    ________________________________________________
    Mac Tech Support MVP
    Addon Author
    http://www.curseforge.com/profiles/mysticalos/
    Thanks...changed
    Any ideas on this Netstat test? Other characters seem to freeze while I'm moving and then they zoom to correct positons.

    traceroute to 199.107.7.45 (199.107.7.45), 64 hops max, 52 byte packets
    1 10.0.1.1 (10.0.1.1) 8.739 ms 5.048 ms 14.436 ms
    2 10.75.135.1 (10.75.135.1) 32.467 ms 22.070 ms 45.309 ms
    3 ip68-4-13-149.oc.oc.cox.net (68.4.13.149) 20.230 ms 10.330 ms 12.126 ms
    4 68.4.15.250 (68.4.15.250) 15.630 ms 11.684 ms 11.415 ms
    5 ip68-4-11-10.oc.oc.cox.net (68.4.11.10) 12.624 ms 14.337 ms 12.297 ms
    6 ip68-4-11-92.oc.oc.cox.net (68.4.11.92) 12.426 ms 12.445 ms 52.595 ms
    7 langbprj01-ae1.rd.la.cox.net (68.1.1.13) 13.440 ms 21.983 ms 11.036 ms
    8 192.205.37.145 (192.205.37.145) 34.652 ms 21.188 ms 25.991 ms
    9 cr2.la2ca.ip.att.net (12.122.129.106) 108.836 ms 108.171 ms 105.006 ms
    10 cr1.slkut.ip.att.net (12.122.30.29) 101.106 ms 103.680 ms 101.638 ms
    11 cr2.dvmco.ip.att.net (12.122.30.26) 114.749 ms 90.131 ms 92.894 ms
    12 cr1.cgcil.ip.att.net (12.122.31.86) 96.514 ms 92.144 ms 87.865 ms
    13 cr1.cl2oh.ip.att.net (12.122.2.206) 112.402 ms 107.551 ms 89.753 ms
    14 cr2.cl2oh.ip.att.net (12.122.2.126) 98.267 ms 94.311 ms 87.583 ms
    15 cr2.phlpa.ip.att.net (12.122.2.210) 86.947 ms 99.228 ms 87.431 ms
    16 gar1.pitpa.ip.att.net (12.122.107.85) 95.891 ms 88.258 ms 85.035 ms
    17 12.122.251.2 (12.122.251.2) 92.536 ms 94.988 ms
    12-122-254-242.attens.net (12.122.254.242) 95.218 ms
    18 mdf001c7613r0004-gig-12-1.nyc3.attens.net (63.240.65.14) 91.888 ms
    mdf001c7613r0003-gig-10-1.nyc3.attens.net (63.240.65.10) 118.884 ms
    mdf001c7613r0004-gig-12-1.nyc3.attens.net (63.240.65.14) 112.951 ms
    2 10.75.135.1 (10.75.135.1) 32.467 ms 22.070 ms 45.309 ms seems a little spikey but hard to say if thats relevent. you may need a more elaborate test to see. have you tried running the line quality test off http://www.dslreports.com/pingtest? it does a more advanced traceroute by using variable packet sizes, and doing it from them to you instead of you to them, they also test it from both east and west coast in US. it may be able to reveal more then your trace shows and is a free test
    ________________________________________________
    Mac Tech Support MVP
    Addon Author
    http://www.curseforge.com/profiles/mysticalos/
    Thanks for the tip.
    I got a message like this on dslreports/pingtest:

    your first hop ping
    stream of 40byte pings
    100% loss
    unknown reason
    You are 74ms
    to your first hop ("high")

    but otherwise got "Pass"
    http://www.dslreports.com/pingtest/5375b843bb49/2858601?r=69
    hmm it didn't perform medium or high bandwidth streams, those were the ones i wanted the most, they really stress the line quality. did you do the test as a guest or did you use a free account that was logged in?

    the 100% loss means your router didn't answer any pings, you may want to login to your modems/routers web interface and see if you can find an option to enable ping to improve the first hop part of test as well. remember to turn it off afterwards.
    ________________________________________________
    Mac Tech Support MVP
    Addon Author
    http://www.curseforge.com/profiles/mysticalos/
    here is a test as a logged in user which allows medium and high bandwidth
    http://www.dslreports.com/pingtest/3766ab374b3a/2858614
    hmm, asside from your first hop being high (that's ISP fail right there). I don't see anything evident that your line is doing any worse at high vs low. which indicates it's probably not a bandwidth or line quality issue. do you lag anywhere else or just in wow itself? it could be an ISP traffic shaping filter misidentifying wow traffic (or maybe they are doing it on purpose) that's affecting your gameplay.
    ________________________________________________
    Mac Tech Support MVP
    Addon Author
    http://www.curseforge.com/profiles/mysticalos/
    Just in WoW (and Vent when WoW is on) but that is only game I use...and only in the last few days. It hasn't gone away or improved at all though. I'll try to contact ISP. Thanks for the help Omegal.
    so you're saying vent does lag when wow does? it's possible then it is an isp problem then that doesn't show in traces we just did since you didn't do them when problem was occuring.
    ________________________________________________
    Mac Tech Support MVP
    Addon Author
    http://www.curseforge.com/profiles/mysticalos/
    I have been having the same problems for over a week and been talking techs with the game. My network is fine. My other toons are fine. It is only on one toon, and i'm lag spiking terribly in bg's, but just subtle spikes elsewhere. I have done EVERYTHING. played without addons, deleted my wtf, cache, and interface folder, deleted curse client, played on low settings. given them tons of diagnostic tests and nothing. I'm at a loss, but so so so frustrated. I have untransmogged my gear...and the crazy thing...this is happening on my computer, my pc laptop. i get on another toon, and i play fine.
    lga15s28-in-f0.1.http
    http://www.speedtest.net/result/1671516252.png
    I recently was in a hotel and played WoW there...during off-hours had no lag. During peak hours had terrible lag. Now I'm home and It's still happening to me all the time. I use latest Snow Leopard OSX.

    My pingtest seemed ok except the "first hop" had 100% failure and a high time (74 ms).

    probably the source of your problem shray, what's your traceroute look like?
    I'm having issues with random lag spikes. My boyfriend plays on a PC on the same network, but he doesn't have any lagging issues. This has been going on for several weeks now...

    traceroute to 206.18.99.21 (206.18.99.21), 64 hops max, 52 byte packets
    1 wl.belkin (192.168.2.1) 25.553 ms 0.965 ms 0.740 ms
    2 cpe-174-100-96-1.neo.res.rr.com (174.100.96.1) 17.007 ms 26.431 ms 11.195 ms
    3 gig3-13.cntnoh2-swt401.neo.rr.com (24.164.112.41) 20.017 ms 34.894 ms 16.476 ms
    4 tge1-6.ncntoh1-swt401.neo.rr.com (24.164.111.241) 12.653 ms 11.304 ms 9.213 ms
    5 gig13-0-0.ncntoh1-rtr1.neo.rr.com (24.164.104.89) 12.034 ms 16.545 ms 17.137 ms
    6 gig14-0-0.ncntoh1-rtr2.neo.rr.com (24.164.104.170) 14.721 ms 45.901 ms 15.536 ms
    7 tge1-0-1.ar01.clevohek.mwrtn.rr.com (65.25.137.237) 18.973 ms 33.327 ms 17.677 ms
    8 ae0.tr00.clevohek.mwrtn.rr.com (65.189.140.144) 21.413 ms
    ae1.tr00.clevohek.mwrtn.rr.com (65.189.140.130) 17.475 ms 22.511 ms
    9 ae10-0.cr0.dca20.tbone.rr.com (107.14.19.14) 32.860 ms
    ae-3-0.cr0.dca20.tbone.rr.com (66.109.6.70) 29.503 ms
    ae10-0.cr0.dca20.tbone.rr.com (107.14.19.14) 28.015 ms
    10 107.14.19.135 (107.14.19.135) 54.377 ms
    ae-1-0.pr0.dca10.tbone.rr.com (66.109.6.165) 79.528 ms 32.916 ms
    11 ix-3-2-2-0.tcore2.aeq-ashburn.as6453.net (216.6.87.69) 55.145 ms
    ix-4-3-0-0.tcore1.aeq-ashburn.as6453.net (66.198.154.13) 58.331 ms
    ix-5-1-0-0.tcore1.aeq-ashburn.as6453.net (66.198.154.29) 54.200 ms
    12 192.205.34.249 (192.205.34.249) 50.001 ms 48.894 ms 54.469 ms
    13 192.205.34.249 (192.205.34.249) 47.092 ms 57.243 ms 49.956 ms
    14 cr2.wswdc.ip.att.net (12.122.220.250) 53.345 ms
    cr1.cgcil.ip.att.net (12.122.18.21) 62.645 ms 53.426 ms
    15 cr1.cgcil.ip.att.net (12.122.18.21) 64.207 ms
    gar2.clboh.ip.att.net (12.122.133.197) 64.499 ms 65.435 ms
    16 gar2.clboh.ip.att.net (12.122.133.197) 44.086 ms
    12.122.251.50 (12.122.251.50) 45.416 ms
    12.122.251.22 (12.122.251.22) 47.151 ms
    17 63.240.130.210 (63.240.130.210) 48.675 ms 47.652 ms
    63.240.130.214 (63.240.130.214) 49.158 ms
    18 * 63.240.130.214 (63.240.130.214) 45.278 ms *
    19 * * *
    20 * * *
    21 * * *
    22 * * *
    23 * * *
    24 * * *


    Hopefully I did that right, it just had the lines of *** at the end, so I stopped it and posted what it had.
    is he plugged directly in and you on wireless? or maybe further from the wirelss then he is?

    1 wl.belkin (192.168.2.1) 25.553 ms 0.965 ms 0.740 ms

    on a belkin wl.belkin indicates wireless dhcp address, and your first hop has a spike there. your lag could be from signal issues such as range.

    Join the Conversation

    Return to Forum