Unable to connect to US armory server

Mobile Bug Report
Just downloaded the app for the first time, and I am getting this error when I try to login to the Americas and Oceanic Region.

Login Failed
Unable to establish connection to server.


The weird thing is, I can login to Europe and Korean servers just fine - Only trouble is, I don't play on those.

Please help - I want to get the mobile AH, but if I can't even connect the the armory, there's no point....


Thanks

Z
Mine is not working either and just before it broke it was DCing me constantly
Yeah I've been fine over the last 5 hours but in the last hour it's been failing to connect to server. I'm being undercut! Gahhhhhh
I cant connect to US server either. Login failed, unable to establish connection to server.
Same here ... Is there an update going on with the app or something?
I'm on a Samsung Galaxy Prevail FYI in case anyone in tech reads this
Busted on the iPhone version as well.
"Unable to establish connection to server"

Yay now I can't use something I pay extra for monthly. Awesome. Time for booze therapy.
Not working for me either, same unable to connect message.

How am I meant to post auctions at work :(
No guild chat while AFK?!?? Sad panda.
And at first, I thought my phone screwed up...
I was able to log in and use this just fine earlier (3 hours ago), but lately I, too, get the "Unable to establish connection to server" message. I am using the iPhone version.

Thanks.
"Login Failed"

"Unable to establish connection to server"

Anyone know why the mobile app. is no working atm?
Starting to think this app is not worth the monthly fee when it never works..

Edit its working again...
Update: I was just now able to log in. Hope you guys can as well.
I have been unable to log in since yesterday, on an iPhone or iPad. Any ETA for a fix?

I log in and get inst-dumped out again. :(


Edit: as of Saturday it's still not fixed. I did submit a ticket and got a response that they are aware of the issue, but they are unable to state when it will be fixed.
Is anyone still encountering this problem?
I get the can't connect to wow armory from Max DPS, Mr. Robot and WoW reforge as of 11 April 2012
01/24/2012 12:42 PMPosted by Wilebosk
Is anyone still encountering this problem?


Yes, just now. I get the unable to connect message and it pops up really quick like the app probably didn't even have a chance to check. I'm having no other connection issues from/with my Android phone.

This is my first time trying to connect since an update last night.
Oops didn't realize thisis kind of an old thread but I can't connect.
04/20/2012 09:36 AMPosted by Worthit
Oops didn't realize thisis kind of an old thread but I can't connect.


http://us.battle.net/wow/en/forum/topic/4512731677

Join the Conversation

Return to Forum