2 Game Launchers at the same time?

Technical Support
So while I am able to get into the game, this issue pops up ever since I downloaded the patch or whatever my launcher downloaded recently (like 24 hours ago).

Every time I click on the Wow Launcher on my start menu, 2 launchers come up.

If I cancel either one, I get an error page which I recently submitted to Blizz, at least I think that's where it goes. The other launcher becomes playable, though. It's an annoyance, but it's still playable.

This only happened after my game launcher downloaded something early morning Pacific time.
I can say that I'm having the same issues. Seems to be something in the update yesterday.
ive got the same problem my self i thought it was a virus or something but im glad to see im not the only experiencing this
Hey guys,

If you're getting two launchers opening up when clicking on the shortcut, make sure you're running the game with administrator status.

Right click on the game shortcut and select "Run as Admin."

________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
What if it already is asking for the administrator rights and still does the double launch after you have typed it in.
03/28/2012 02:21 PMPosted by Wafectus
ive got the same problem my self i thought it was a virus or something but im glad to see im not the only experiencing this
Yeah same here. I was worried I was getting some fake launcher.
Inoculah,

03/28/2012 05:37 PMPosted by Inoculah
What if it already is asking for the administrator rights and still does the double launch after you have typed it in.


What are you seeing that is asking for administrator rights?

Were you able to set administrator permissions by right clicking and selecting that option?

________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
After patching to 4.3.3 i had this problem.

All I did was delete the launcher.exe from my WOW folder.
Then repaired my files using the "repair tool".
Right click the new "launcher.exe" and select 'properties'.
Under the 'Compatability' I checked the box that says 'Run this program as an administrator'.
Which is located under the 'Privelage Level' section.
Hit "Apply" then "OK"

Works fine now and I DO NOT have two launchers loading.
Before people ask:
I am runing Windows 7 Home Premium. This should work for Vista and all versions of 7 as well. Hoope i helped :D
Happy gaming!!
This seems to be a problem with permissions on the registry key described in the link below once I changed the permissions I no longer had to run as admin or had to deal with 2 launchers.

http://us.battle.net/wow/en/forum/topic/3123035953?page=1#5

Join the Conversation

Return to Forum