Launcher starting up twice

Technical Support
Lately, when I start up WoW, I get two launchers instead of one, as if my computer has decided to run two separate installations at the same time. The game, once I log in, runs fine and I have no problem with it, but I can't figure out why suddenly one click on my WoW icon gets me two launchers. I'm running Windows 7 64 bit on a toshiba Qosmio, and haven't made any major changes to my machine lately, so I'm at a complete loss. Any thoughts?
I am having the exact same problem - did you do a direct download install on that box? the WoW version I am running was copied from my spare drive and on the newest install of the box I built this week I am getting two copies of the launcher from one icon click or double click action...
I had the same problem. I'm using windows 7. If you go into the wow folder right click the launcher go to properties then compatability tab and make sure run as admin is checked. This fixed it for me
That did the job Kryppa - thanks.
fixed here too. ty
we have 2 pc's in house here on WoW an 1 of them are running Windows 7 64 bit ... it too had the twin launcher problem. We tried the admin permission tick BUT it then screwed with vent. yes only 1 launcher would work but only way to use vent was to be alt-tabbed out of WoW, second was back ingame, you could listen to vent but could not transmit. we have removed admin from launcher an gave it to vent. its a ezy matter of closing 1 of the launchers ( or leave it , it dont affect anything ) an now it all runs. fine.
I had the same problem. I'm using windows 7. If you go into the wow folder right click the launcher go to properties then compatability tab and make sure run as admin is checked. This fixed it for me


This worked for me. Thanks. ^_^
06/30/2012 02:43 AMPosted by Froststeppa
we have 2 pc's in house here on WoW an 1 of them are running Windows 7 64 bit ... it too had the twin launcher problem. We tried the admin permission tick BUT it then screwed with vent. yes only 1 launcher would work but only way to use vent was to be alt-tabbed out of WoW, second was back ingame, you could listen to vent but could not transmit. we have removed admin from launcher an gave it to vent. its a ezy matter of closing 1 of the launchers ( or leave it , it dont affect anything ) an now it all runs. fine.


You need to right click vent and also run it as admin.

Join the Conversation

Return to Forum