PC Crash Radeon 7970

Technical Support
Prev 1 2 3 14 Next
I'm using a 7970M and have the same issue. Only seems to happen in raids. The screen goes black and sound stutters. I have to do a hard reset to get the machine back up.

How do I move back to DX9 from DX11?

Thanks.
Tinymanjr,

Select Advanced from the Options menu in game and then switch the Graphics API to Directx 9 to switch over to that setting. You'll need to restart the game before the change takes effect.
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
Thank you.

For what it is worth, switching to DirectX 9 did not change anything. I still crash using DX9.
One thing I have noticed. When running the Hour of Twillight instance where Thrall leads you to Wyrmrest I always, 100% of the time, crash hard to a black screen during the fight with the assassin where she throws that red cloud that obscures your view. It doesn't happen the first time she throws it, but it always happens during one of those phases.

Over and out for now.
I have been having similar issues with my game. Wow seems to be the only game affected by this and i cant seem to find a solution anywhere. Started after the most recent patch as well.
Hey there,

I'm glad I'm not the only one. . . My entire computer crashes when I play WoW. Not only in a raid, but in a dungeon or a battleground. And I know that a few others have had this problem like I have.

There was a recent update, and my computer was running just fine before the update. But now, when I am in a dungeon or a raid or a battleground, it just shuts off. It doesn't say anything is wrong, but my computer will shut off automatically. And after that, even if I check out my email or something, it'll shut down on its own. My computer is pretty new and hasn't had any problems, and it is in a very good shape. . . I just want to ensure I don't need to get a new computer already.

Before I start playing WoW, it runs just fine. . . but when I do play, it shuts down. Could you figure out what the problem is?

Thanks,

Lunaxia
05/27/2012 09:50 AMPosted by Beersham
I have been having similar issues with my game. Wow seems to be the only game affected by this and i cant seem to find a solution anywhere. Started after the most recent patch as well.


One more bit of information.

If I run in Full Screen mode, I can't play at all. The screen (even the login screen) jitters and shows tears as well as random boxes of color.

If I switch to Full Screen Windowed I can play, but it always crashes to black screen eventually.
A little more information if it helps.

I'm running the stock Dell drivers and if I disable XFire and run in Windowed Full Screen I seem to be able to avoid crashing. With XFire or in Full Screen and it always crashes.
I am having the exact same issue with my 7970 (sapphire 3GB).
Screen freeze + buzzing sound from speakers.

This is on a fresh install < 3 days old with all the latest drivers for all of my hardware.

I do not have any crashes in Rift or Star Wars, The Old Republic.

I cannot say if it just happened since patch because I just re-subbed my account yesterday.
I'm having the exact same problem with a Radeon HD 7870. Computer is 4 days old now, and no other issues with any other games except for this. Also (while tanking) I 100% crash on Spine.. when the amalg has 9 stacks, and is starting to blow.... Every other time it's random.
I'd really hate to kick a 7 year addiction... but what is one to do when they can't really participate in the one thing they really enjoy with WoW? People don't want to raid with a tank who is having problems with WoW crashing.
Hey there,

I'm glad I'm not the only one. . . My entire computer crashes when I play WoW. Not only in a raid, but in a dungeon or a battleground. And I know that a few others have had this problem like I have.

There was a recent update, and my computer was running just fine before the update. But now, when I am in a dungeon or a raid or a battleground, it just shuts off. It doesn't say anything is wrong, but my computer will shut off automatically. And after that, even if I check out my email or something, it'll shut down on its own. My computer is pretty new and hasn't had any problems, and it is in a very good shape. . . I just want to ensure I don't need to get a new computer already.

Before I start playing WoW, it runs just fine. . . but when I do play, it shuts down. Could you figure out what the problem is?

Thanks,

Lunaxia


If your machine is just shutting down, then most likely it's a power supply issue.
What's the brand and wattage on your PSU? Are both of the PCI E connectors connected on the 7970?
FYI, DX9 worked great for a bit, but still crashed last night for me (more stable, but still seemingly an issue). When can we expect a fix for this?
Have you tried the 12.6 beta drivers to see if it fixes your problems? My freind has one of the 7900 series cards and the beta drivers solved his crashing isue with wow.

http://support.amd.com/us/kbarticles/Pages/AMDCatalyst126beta.aspx
yup... I installed those yesterday morning, and it crashed last night around 12am after turning in a quest..
Thought i would ask. Its not just WOW and the 7000 series cards. Tom's hardware is full of people having problems with them and many other games.
06/04/2012 07:07 AMPosted by Northernlite
Thought i would ask. Its not just WOW and the 7000 series cards. Tom's hardware is full of people having problems with them and many other games.


Interesting...... Thanks for this, was almost certain WoW was the culprit. Upon looking at the forums, I can see what you mean.
I am also experiencing the same troubles with the 7970. Switched out the power supply just in case that was the factor in which it was causing the problem. After a few hours of game play, my computer freezes and makes this loud buzzing noise. I have to hard restart my computer, because task manager will not open up. Another issue is that when I sometimes go into windowed mode, then come back to full screen, my computer just goes dark. I can not do anything, and again, have to hard restart my computer. I could say that this may be from the new patch, because I was not experiencing this from the past. However, these incidents do not occur always. I have once had at least two days of gaming without the problem, but it always persists.
For those of you that have a 7000 series from saphire here is there thread. They can offer firmware upgrades if the tech thinks it will fix your problems its not just wow same problems your describing from many games . it might help. every card manufacture has a suport forum might be a good idea to check out the one for your card. Some are offering firmware upgrades for certain problems

http://www.sapphireforum.com/?psn=000205&lid=1
You may want to try to roll back to the 12.3 drivers. I've had no WoW issues with them. (I do have crashes coming back up from sleep, but that's a known problem with this driver and card).

12.4 and 12.6 beta both crash hard in raids apparently randomly. I've reported it to AMD but they haven't fixed it yet. But more reports will probably push it up the priority list.

Join the Conversation

Return to Forum