[Solved] Unable to Login to Moble Armory

Mobile Bug Report
Good Afternoon,

There appears to be an issue with the Mobile Armory. I'm getting "Login Falure - Connection Error. If you are connecting via Wi-FI, the access point you are connecting may be blocking port 8780. I get this on WI-FI and 3g so i think its a armory issue as opposed to a router issue.

-Thanks
Its working now but its really slow.........to post or or browse
I'm having the same problem. Checked router settings. Reset router. Tried connecting via wi-fi and 3g. No luck. On 3g I get a 'connection timed out' error.
I have been having problems logging in this morning too. I did get it to log in once right after the maintenance was over but it was running really slowly and when checking my sold auctions they were all duplicated. I was going to try logging off of the mobile app and logging back on to see if it fixed it, but have not been able to log back on since I keep getting "Connection Error: Unable to establish a connection to server." on both Wi-Fi and 3G, all other apps and web browsing still work.
I am also having this problem on 3G. I haven't been able to try over wi-fi. I'm using an iPhone 4. I was able to connect at terribly slow speeds right after servers came back online but have been unable to connect since.
We're looking to get this resolved ASAP.
I just updated to the version that was released 4/20/12 (I guess version 2.3.0?) and it logged in and seems to be working just fine after the update. Not sure if it was the update or the service just coming back online.
I am having a similar issue -

***
Login Failed
Unable to establish connection to server.

[Okay]
***

This is an iphone 4S on "4g" (Yeah, it's really modified 3g, but ya know, AT&T made the logo change after all that fighting with the FCC) full bars.

I have tried re-installing the app and double checking password.

Hope that helps! I've never had any issues before, but I just got wow mobile like yesterday, and though it worked fine then I do worry maybe it's a problem with authenticator? I dunno.
Anyway, thanks!
Same here!

Iphone 4S. Telus Carrier. BC Canada.

"Unable to connect to server.....iRBroKEn"
After investigating further it's only affecting builds without Push Notifications, so pre-2.3.0 Android builds are not working and the current iOS 3.2.0 build is not working. 2.3.0 Android builds are working, however.
Does Blizzard intend to enable push notifications on iOS? If so, that would be awesome. It would be nice to get reminders before events and know when auctions have sold.
Is there a fix coming for those of us who's providers have not updated us past 2.3? Cause if not it would be good to know now so we can cancel the service rather then pay for something that does not work.
05/08/2012 01:50 PMPosted by Wilebosk
After investigating further it's only affecting builds without Push Notifications, so pre-2.3.0 Android builds are not working and the current iOS 3.2.0 build is not working. 2.3.0 Android builds are working, however.


That is great. Thank you. So what is the resolution to this problem for those of us on iOS 3.2.0?
05/08/2012 01:50 PMPosted by Wilebosk
After investigating further it's only affecting builds without Push Notifications, so pre-2.3.0 Android builds are not working and the current iOS 3.2.0 build is not working. 2.3.0 Android builds are working, however.


If indeed this issue impacts the whole iOS installed base, is there a plan to rollback whatever change was made during maintenance this morning that is causing the issue?
I'm not sure that's the case. I'm using an iPad 2 and having the same problem, but my version (5.1) supports Push Notifications. I've checked and the WoW Mobile Armory doesn't display on the Notification Centre page.

I've tried reinstalling the Armory and it doesn't seem to help. Thoughts?
I'm not sure that's the case. I'm using an iPad 2 and having the same problem, but my version (5.1) supports Push Notifications. I've checked and the WoW Mobile Armory doesn't display on the Notification Centre page.

I've tried reinstalling the Armory and it doesn't seem to help. Thoughts?


The version Wilebosk refers to is the version of the iOS app, not the OS itself. The most current release of the Mobile app for iOS is 3.2.0, which does not have push notification support.
Ahh, got you! Sharpest tool in the shed, am I.
This has been resolved now.

And sorry for the version mix up above. Mobile Armory v3.2.0 for iOS is what I had meant. :P I'll try to define OS versions versus Mobile Armory versions for different platforms more accurately.

Join the Conversation

Return to Forum