Unable to logoff?

Mobile Bug Report
Post Limit:
Its still effecting me. My main is stuck online 24/7.

The app is logged out, and I completely UNINSTALLED IT. And Im still online 24/7. I can even send myself PM's from an alt, and it just says "Cipherr is Away"
I posted this in my own thread, but I guess this applies here we well.
After posting this
I am currently signed in on this character into "remote chat" but i do not have the mobile app installed on my phone.
I tried it a few weeks ago and uninstalled it, haven't had any issues with it until now. So why and how am i signed into remote chat on a my main when I'm playing my alt and do not have the app?


A friend suggest I download the app again install it, log in and Do a log out. And it worked.... So i uninstalled the app again and everything was good last night and today.........until just now. My main toon signed in again on remote chat.......
I have even changed my password to no avail, my character keeps signing into remote chat and I have found no permanent fix to keeping the remote chat feature completely disabled.
It only started happening yesterday, 9/1.
Having the same issue. Trying logging in to this toon on remote guild chat, received an "Chat Connection Error: Connection timed out." error, then logged out of the app. However, now this toon is stuck online constantly in game.

I have tried to uninstall the app, turn off/on my phone, and nothing. However, I still receive the "connection timed out" error each time I attempt to log on guild chat with this toon (haven't tried with others as I don't want all my alt's stuck on >_<)

Using an iPhone 4s
Having the same issues. My main was kept logged on 24/7, so I uninstalled the app from my phone. However, whenever I'm logged onto an alt, it still shows my main logged on via Remote Chat despite the Armory app not existing on my phone. Using an iPhone 4.
From what I can gather, this is working as intended -- and not the cynical "working as intended", but actually the way it was designed and tested. The way this feature works is that if you do not physically log your character off in the Guild Chat module, you will remain in a "Mobile Away" state indefinitely. (Our latest testing clocked it at around a month, but it will vary.)

The reason we do this is because we cannot assume why you've left the application, because the nature of a mobile device is such that you could be intermittently disconnected dozens of times in a single session. We don't want you to be in the middle of a whisper conversation with someone and then have their follow up text go into a void, because you lost reception. Thus, by not assuming you intended to be disconnected, we're helping preserve what could be a very important conversation.

This ability to receive whispers even when temporarily disconnected and to preserve them over long periods of time is a key feature that has caused some, at first glance, odd scenarios such as those being reported in this thread.

However, if you have logged yourself out manually from Guild Chat, and you still see yourself as Mobile Away or Online, let me know.

(Also, FYI: If you're logging into multiple devices, there are edge case scenarios where you can log into one device, then log into a second device, causing the same always-online issue. The way you resolve this is by physically logging out of the first device to clear that instance of Mobile Away. Sorry, it gets a bit convoluted when you break into the multi-device situations.)
Thanks for your help. I went ahead and reinstalled the app, logged back in and then logged off and it resolved the issue.
I am having this issue also. I have selected "Offline" along with "Logout". I have uninstalled and reinstalled the app three times and have even changed my password. I have never signed in on another mobile device.

I am frustrated and annoyed. This problem didn't start happening to me until the armory app went 100% free. If there are any other possible fixes that I haven't tried I would like to know. Thank you.
I am having this issue also. I have selected "Offline" along with "Logout". I have uninstalled and reinstalled the app three times and have even changed my password. I have never signed in on another mobile device.

I am frustrated and annoyed. This problem didn't start happening to me until the armory app went 100% free. If there are any other possible fixes that I haven't tried I would like to know. Thank you.


There are some edge case scenarios where a mobile server hiccup could cause this during a realm restart, but that is pretty rare. Still, with a game as large as WoW, a lot odd unanticipated issues can and will crop up.

You could also potentially encounter this if you were logged in with an older build (pre-3.3.0/2.3.2), signed into Guild Chat, and then upgraded to the latest build -- which may cause the server to think the Guild Chat instance from the previous build is not the same as the login on the upgraded build. Updating your OS could potentially cause something similar, but this is speculation.

A server restart may resolve this naturally. Right now I don't have a work around if it's related to any of the above, but it's on my top watch list. You may wish to try logging into the game and mobile simultaneously and then log off the 2 in different orders, vary your patterns a bit.
My mom's character gets this sometimes...we log into a second device and take her offline and it fixes it temporarily then a few days later, she's back online again. So we log into the second device and do it again then a few days later, she's back online again.
I downloaded the app to my Samsung Note yesterday and tested it out. Worked great until I realized this morning that the game still shows me logged in and online in the "Remote Chat" zone. I've tried logging in and out on the app and the game and still shows me as online. Uninstalled the app and reinstalled...still online. I have noticed that there is a small symbol next to my name that goes green when I actually log in to the app on my phone and then turns yellow when I log out. So it sees me logging out, but still says I am online.

I just tried to whisper to my main from an alt and my zone in player status changed from "Remote Chat" to "Stormwind" and still shows me as online but the return message I get is that I am away. Then 2 minutes later...my toon disappeared from the guild status window.
So I'm having similar problems, I've tried everything that has been listed above. However the only thing I can't try is logging in and then logging out because it comes up with the connection issue.

Basically this character, every time i log in with him it lists him as remote chat, even if the phone is off and sim card is removed. If I log onto another character tho, this character logs off as well, no remote or anything.

I'm using an iphone 4s, latest versions of both phone and app
Currently having the same issue and i dont even have the app. installed on my phone any longer. needless to say im am extremely confused!
was having the same issue as the others,
removed the app from my phone pulled the battery simcard and SD card
turned the phone back on installed the app
same issue as before

however what i did to resolve this issue is as follows
logged on to two different characters one in game and one on the app via my phone exited the guild chat on my phone and closed out the app and everything is working as per normal again
I was having this issue as well, but after going through so many attempts, one thing finally worked for now(the last):
-simply logging off in game and logging back on
-full WoW restart
-logging off in Mobile chat
-going offline in Mobile Chat
-going offline then logging off in mobile chat
-uninstalling
-reinstalling and repeating above methods
-logging onto alt on Mobile, and Ren in game(showed BOTH as online on Mobile)
-logging on Ren on Mobile, alt in game(shows both online, Ren as Mobile)
-logging on alt on Mobile, alt in game(shows one alt in mobile, one alt not in mobile, and Ren on Mobile)
-logging out of Mobile, while alt in game(leaves all 3 in guild, no mobile status)
-logging off of Mobile while in game on alt from above, then logging onto Ren in game and leaving Mobile off

This was extremely frustrating to fix!
I found a different "solution" for my case. I logged in both the mobile app and game with this main (Fermotar) who is having the issue and then I selected the "offline" from the guild chat window(top left icon) instead of logging out of the application. that fixed my state instantly but it comes back to "remote" after 10 seconds!!

I am wishing I never installed this app in the first place, my guildies think Im mobile all the time and cant see where I am.

I have an Iphone 4S with the latest version of armory, tried all the steps I saw in this thread
You can look at this toon right now and see that it is labeled as being on remote chat even though I am not currently on it. When I watch my guild status, this is what happens:

I come online in game and it says I am on remote chat which I am not and even says I am actively on it with the green online icon, I am totally logged off everything mobile.

I log into my mobile account and flip the guild chat to online, now I am actually online in game and on my mobile on the same toon.

I flip off my mobile guild chat to offline and with my open guild panel window in game says my status changes to org....showing I am offline on my mobile.

Then anyone of these things will make it go back to being online for remote chat:

1. If I close my guild panel window and reopen it, it immediately shows me as again being online on remote chat even though I didn't change anything on my phone.

2. If I keep my guild panel window open, the org status will automatically change from within 1 second to like 30 seconds back to remote chat but I see it move from remote chat to org for a short period of time.

3. If I am able to find a 5 second time period where I can log off guild chat on my mobile, go back to the main menu on my mobile, log out of the app totally, and close the app on my mobile, I can get it to look like I am finally offline in game however it is a timer because I will show back up as remotely on again. However, by doing it this way, at least my toon isn't showing up in the guild roster as being online actively. If you go to the guild panel and hit "show offline members", you can find this toon, it went back to Remote Chat, and it even has the active green online icon even though it is obviously not online since you have to hit the "show offline members" just to find it.

4. If I log my druid off remote chat and flip to another toon on remote chat, druid goes back to remote chat also. If I log out the new toon from remote chat, it leaves but stays on the guild roster like it is standing in org which it isn't and my druid stays on remote chat.

It is stuck in a state of being online remotely for over a day now. I am on an Iphone 4s and uploaded the application yesterday and since haven't been able to get the toon offline on it.

Edit - I totally deleted the application and I am still considered actively on remote chat.
After experimenting, I got myself off finally. It has something to do with the app being open while you are logging into the game. If the app or game are open at the same time, it sends it into this forever log into remote chat pattern. I had to totally shut down my computer and while it was off, totally log out of the application. After I went back into the app, I logged into my guild chat on my mobile and then logged out of guild chat and then logged out of the app. When I rebooted my computer and logged into the game, I was finally not on remote chat anymore.

My issue was I had the app on talking to people while I was logging into the game and it seemed to send it into this cycle. My fix this time was to make sure everything cpu wow related was totally off, log into mobile app, log everything off (chat and app), then boot game and log in.
Im having the same problem I can't even log into the guild chat and when u log in into the game it sayres i'm in the remote chat
After experimenting, I got myself off finally. It has something to do with the app being open while you are logging into the game. If the app or game are open at the same time, it sends it into this forever log into remote chat pattern. I had to totally shut down my computer and while it was off, totally log out of the application. After I went back into the app, I logged into my guild chat on my mobile and then logged out of guild chat and then logged out of the app. When I rebooted my computer and logged into the game, I was finally not on remote chat anymore.

My issue was I had the app on talking to people while I was logging into the game and it seemed to send it into this cycle. My fix this time was to make sure everything cpu wow related was totally off, log into mobile app, log everything off (chat and app), then boot game and log in.


I can confirm that there is indeed an issue with being logged in-game and in the Mobile Armory that can cause problems for your mobile presence. I've already informed the WoW team and they are looking into it.
my zone shows remote chat even when im logged on to my charchter please help it wont show my zone as soon as i go offline it shos my zone but when i exit the app it goes to remote cht again

Join the Conversation