Mobile armory is junk!

Mobile Bug Report
Doesnt work. Won't log on and finally when I can log on it boots me. Of course u can't EVER get ahold of ANYONE at blizzard. And of course all u can do is write this stupid thread that NOBODY from there will ever read. I WANT MY MONEY BACK!!! This is ridiculous that I have to pay for this total junk
Are you using the Android Mobile Armory or iOS? What is your OS version? What version of the app are you running? Are you connecting via WiFi, 3G, or 4G?

We had some server load issues today that affected the Mobile Armory, but after restarting the impacted service it should be working pretty well now, aside from the usual carrier problems. I'll do my best to help you out, so let's get a discussion started!
Screaming at Blizzard won't help. Wilebosk is already very helpful and asking to keep the discussion going to figure out what is wrong.

Second, you never had to PAY for the app. It's FREE. You only have to pay if you want RC.

for Wilebosk, I'm having "handling" errors on the iOS version, 3.3, iOS 5.1.1. logging in or even sometimes in the app, search for something, bamn get hit by that error and boots me out. I've used it on WiFi and 3G, same error. been a week now, if that helps! :)
Ok - Next Question. ive been using Mobile armory forever. im deployed over in Qatar right now and i just updated to the newest version. since i updated it i have not been able to log in.

im not mad if its just a simple glitch.

but if it is not fixed id like my refund for the money i pay for remote chat and remote Auction house.

Phone - Atrix 4g
Mobile Armory - 2.3.2
Droid OS - 2.3.6
Connection Type - Wifi
Screaming at Blizzard won't help. Wilebosk is already very helpful and asking to keep the discussion going to figure out what is wrong.

Second, you never had to PAY for the app. It's FREE. You only have to pay if you want RC.

for Wilebosk, I'm having "handling" errors on the iOS version, 3.3, iOS 5.1.1. logging in or even sometimes in the app, search for something, bamn get hit by that error and boots me out. I've used it on WiFi and 3G, same error. been a week now, if that helps! :)


I've noticed that we get more errors on Sundays. (I'm looking into this.) Is this still happening for you?
Ok - Next Question. ive been using Mobile armory forever. im deployed over in Qatar right now and i just updated to the newest version. since i updated it i have not been able to log in.

im not mad if its just a simple glitch.

but if it is not fixed id like my refund for the money i pay for remote chat and remote Auction house.

Phone - Atrix 4g
Mobile Armory - 2.3.2
Droid OS - 2.3.6
Connection Type - Wifi


When did you upgrade? Have you tried logging in during varied times of the day? We've had some instability at peak hours, which we're working to address very soon!

Join the Conversation

Return to Forum