Launcher Redownloading?

Technical Support
Right... so I've run the WoW Launcher as admin for... idk a year now? Last night I didn't run as admin...

I know why I always ran it as admin now.

It is requiring me to download the ENTIRE game again. Someone want to help me with this? I have really really low bandwidth (4 mb/s download, .4 mb/s upload).

Anyone?
Contorted

Where do you have the WoW folder currently installed?
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
Contorted

Where do you have the WoW folder currently installed?
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time


I apologize greatly for not replying sooner, had something to take care of.

L:\Games\PC Games\World of Warcraft

I moved it off my SSD *A WHILE AGO* to free up space. But that is where it's located (it's an HDD not an external drive)
Contorted

That folder location should be fine.

Try this:

1. Go into the World of Warcraft folder
2. Delete the Updates folder
3. Delete the Launcher.exe
4. Run the repair.exe
5. Once the repair is done, run the launcher.exe as an admin
6. Let the launcher download until it is completely up to date.

Then test out the game and let me know what happens.
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
Contorted

That folder location should be fine.

Try this:

1. Go into the World of Warcraft folder
2. Delete the Updates folder
3. Delete the Launcher.exe
4. Run the repair.exe
5. Once the repair is done, run the launcher.exe as an admin
6. Let the launcher download until it is completely up to date.

Then test out the game and let me know what happens.
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time


You don't understand. I don't want to download 8GB worth of data. Is there a way around this?
Contorted

There is no reason why the data would need to be redownloaded if it was already applied. The only reason would be if the data was somehow corrupted, which can be caused by a system restore and other factors. If the data is corrupted, there is no way around it, and it will need to be redownloaded.

If the data is not corrupted, then the steps I suggested should help. Did you even try them?
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time

Join the Conversation

Return to Forum