Multisampling (AA) over 2x is gone

Mac Technical Support
The multisampling option of 4x, 8x and 16x, have simply disappeared. Completely gone, not just greyed out. Before patch 5.0.4, and after it (for about 10-15 mins), all the options were available. Now all I can choose from is 1x and 2x. On top of that, even if I choose 2x, every time I reload WoW it resets itself back to 1x.

Is this a bug or was the patch meant to take away these options? Multisampling resetting to 1x is a bug I believe, but not sure about the other one. Now my game just looks raw and jagged. :(

Anybody else experiencing this?

Specs:

Model Name: MacBook
Model Identifier: MacBook7,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MB71.0039.B0B
SMC Version (system): 1.60f5

Chipset Model: NVIDIA GeForce 320M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x08a0
Revision ID: 0x00a2
ROM Revision: 3533
Displays:
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected

[edit: added specs]
I can get 8X multi, gotta disable that new one (SMAO or something), sunshafts off, water fair. :)
08/29/2012 12:11 AMPosted by Owleye
I can get 8X multi, gotta disable that new one (SMAO or something), sunshafts off, water fair. :)


Even with every setting to low/disabled, I still don't even see an option to go higher than 2x AA. If it was like this ever since patch I might think it was just changed, but I had it at 4x right after servers got back up so I know it should be there.. :/
The developers probably decided multisampling above 2x was too high for your integrated laptop card. I can't go higher than 2x on my Radeon 2600 (which is the stated minimum requirement for the game).

Or maybe it's a bug, who knows.
I'd hope its a bug. I've ran 4x and 8x flawlessly in the past, no reason it would be too high.

Hoping for a Blizz post to clear things up, but I doubt they'll post here until all the "stuck, cant login" kind of problems are fixed. >.<
Hopefully it's just a bug, because all the fancy graphic effects mean nothing if it looks jagged and ugly.
I've got AA 4x with everything else at High. No 8x though. Maybe they disable features depending on features? I have a fairly capable 5770. The AA setting doesn't stick though and needs to be put back in after each restart.
Any News with this issue?
I've just logged in and am having this same issue.
The game used to run flawlessly on 4x multisample and used to look good.
Now everything is just jagged! Would love to NOT lose this feature
This isn't a bug. We've updated the MS/AA requirements. It is listed in our new sticky here: http://us.battle.net/wow/en/forum/topic/6471447232

Multisampling Updates

    Multisampling on the Mac client has changed with patch 5.0.4:

    The max multisampling for World of Warcraft on Mac is now 4x. In addition, available options for multisampling will be based on the amount of VRAM:
    • 4x requires 512 MB of VRAM
    • 2x requires 256 MB of VRAM
    • 1x will be the only option available for Mac users with less than 256 MB of VRAM
It's a shame. I couldn't turn multisampling on unless I turned off almost everything else. Game used to look wonderful with it on. Guess it's time to go back to Super NES. I was ready for MoP, but this issue, it ultimately led to my decision to quit and not renew my sub. I hope they fix it for the sake of other players.
This is always being evaluated.

There was some driver/OS issues that caused problems for WoW on Mac. We're working with Apple/NVIDIA/AMD to help address some of the issues to allow higher Multisampling settings to be enabled without causing issues for the game/OS.
________________________________________________
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!

Join the Conversation

Return to Forum