Warlock Havoc Macro

UI and Macro
So im not sure if this is possible, but im trying to create a macro that if i have an enemy targeted, it will target the next/closet enemy, cast spell Havoc, then target my original/previous target

Ive tried everything i can think of
Ex.
/targetenemy
/cast havoc
/targetlasttarget
and quite a few other commands which doesnt work.

If its not possible, even a macro that will cast havoc on nearest target then target my focus will work. Any help would be appreciated

I tried
/targetenemy
/cast havoc
/target focus
which doesnt work either. it just casts havoc on my current target
You can only use one instance of a targeting command at a time in a macro.

* http://www.wowpedia.org/Making_a_macro#Targeting
/targetenemy, /targetfriend
These commands cycle through the specified type of unit. /targetenemy is like pressing TAB, and /targetfriend is like pressing CTRL-TAB. You can also add a parameter of 1 which reverses the direction of the cycle (/targetenemy 1 is like pressing SHIFT-TAB).
Note: You can only use these commands once per macro.
You can only use one instance of a targeting command at a time in a macro.

* http://www.wowpedia.org/Making_a_macro#Targeting
/targetenemy, /targetfriend
These commands cycle through the specified type of unit. /targetenemy is like pressing TAB, and /targetfriend is like pressing CTRL-TAB. You can also add a parameter of 1 which reverses the direction of the cycle (/targetenemy 1 is like pressing SHIFT-TAB).
Note: You can only use these commands once per macro.


Doesn't appear to be so...
Simple macro I just put together because I could swear you can have two instances of a target command...
And it works just fine...

#showtooltip
/targetenemy
/cast Corruption
/targetlasttarget

Happens so quick the target change doesn't even show up for me..
Corruption is just on the other target..

I always use #showtooltip when it's a short macro because I'm fancy!

Don't know what the problem is OP, worked just fine for me just now on Corruption..

Edit: That is REALLY weird..
I just switched into Destro and so far that macro adapted to anything in Destro hasn't worked the same as in Demo........
I smell a silentgimping...

SecondEdit: I've got it to work somewhat..
On Curse of the Elements it's really touchy but will work some of the time...
As if it doesn't want to target a target it's already targeted in that same session of combat...
I don't know..

ThirdandfinalEdit: Success!!
I've figured it out....
Really odd it doesn't seem to work this way when I'm Demo...

It APPEARS to work basically the equivalent of a 'target center screen' command..
The target you want Havoc on needs to be at the center of the screen, regardless of having him targetted..

So I.E.

Enemy to the left, enemy to the right.
You target left, you want havoc on right.
Face right, cast havoc.
Havoc should be casted on enemy at right, while you retain enemy at left as your target..

And then the enemy at the gates show up...

Sorry, yeah, long post, I get carried away.

Hope this helped you out.
Thanks a lot that makes a lot of sense. When i was testing it, i was standing in the same spot the whole time with main target in the center of screen.
another weird thing is i made a macro like

/cast havoc
/targetenemy
/target focus

it will cast the spell on main target, but if i press it again it will cast it on the nearest target (thats not my current one) then if i wait like 10 secs it restarts...very weird

Join the Conversation

Return to Forum