Spec and Icon info missing from Guild api

Community Platform API
I just tried to check my rogue on the guild api and his spec and icon information is missing, all other classes have this information except the following classes: priests, shamans and warlocks. So once again that's priests, shamans, rogues and warlocks icon and spec information is missing. I know this because my guild roster script i use works fine for all other classes except those classes i mentioned above.

lets try and explain this in detail..
http://us.battle.net/api/wow/guild/whisperwind/reprisal?fields=members,talents

{"name":"Kneep","realm":"Whisperwind","battlegroup":"Rampage","class":4,"race":1,"gender":0,"level":85,"achievementPoints":10020,"thumbnail":"whisperwind/51/90945587-avatar.jpg"},"rank":2},

notice no icon or spec info to be found anywhere

now if i check

http://us.battle.net/api/wow/character/whisperwind/kneep?fields=talents

it works fine and is more detailed.

Thanks, Slyvester
The caches for this data are very slow to update. This is something we were going to look into later on. So far every reported case (achievement points not updating fast, spec not showing up fast, etc) update within a couple of days from the report.

It's also possible that some of those characters on your list haven't logged in since 5.0.4? (I know this isn't the case for all of them, such as the character you link).

We will be looking into these caches (they also serve the character tooltips) hopefully soon after MoP launch in order to speed them up.

As an FYI, "talents" is not a field option for the guild api, the spec should show up with just "fields=members".
The caches for this data are very slow to update. This is something we were going to look into later on. So far every reported case (achievement points not updating fast, spec not showing up fast, etc) update within a couple of days from the report.

It's also possible that some of those characters on your list haven't logged in since 5.0.4? (I know this isn't the case for all of them, such as the character you link).

We will be looking into these caches (they also serve the character tooltips) hopefully soon after MoP launch in order to speed them up.

As an FYI, "talents" is not a field option for the guild api, the spec should show up with just "fields=members".


Well some of the characters haven't logged in since the patch. I do know some that have, as they just played for the last week or so. The reason why i replied was b/c if you look at the some of the data in the first link, it's like it's only affecting certain classes and not others? At first, I thought maybe they have to have glyphs along with there spec, but that's just not the case here. I do recall when the wow api was updated for the new patch, it affected shamans having a subtlety spec, hopefully that wasn't related to any of the rogues or shamans in my guild not having a spec name or role?

Peratryn, thanks again for all the hard work you do at blizzard, without you some stuff would never happen. I hope it gets fixed ASAP, so i don't have to do manual updates of my guild roster the hard way : /. BTW, thanks for the tip on fixing the link.

Join the Conversation

Return to Forum