WoW shuts down minutes within entering

Mac Technical Support
I have mac os.x 10.6.8 and every time I log on to WoW now, it completely exits out of the game with no warning or error report. I have no add-ons. I deleted the WTF, Cache, and Interface folder. Please help!
Can you post your full system specs? This will help us out.

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)

Also, can you try resetting permissions to the WoW folder and see if it helps?

Reset the permissions on your World of Warcraft folder
    1. Select the World of Warcraft folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Action icon (cog wheel) and select Apply to enclosed items
Hardware Overview:

Model Name: MacBook
Model Identifier: MacBook6,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.26 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 2 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MB61.00C8.B00
SMC Version (system): 1.51f53
Hardware UUID: 344E9F2F-E2DF-5E35-B4BF-580A8A1A9DF5
Sudden Motion Sensor:
State: Enabled


NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0863
Revision ID: 0x00b1
ROM Revision: 3462
Color LCD:
Resolution: 1280 x 800
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Display Connector:
Status: No Display Connected

System Software Overview:

System Version: Mac OS X 10.6.8 (10K549)
Kernel Version: Darwin 10.8.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Computer Name: Akins MacBook
User Name: Akins (dakins840)
Secure Virtual Memory: Enabled
64-bit Kernel and Extensions: No
Time since boot: 4 days 23:41

Also tried resetting permissions, didn't fix anything!
I would say you're likely hitting a memory breakpoint. You have 2 GB RAM, and the 9400M

Graphics Card NVIDIA GeForce 9400M
Graphics Memory 256 MB of DDR3 SDRAM shared with main memory (Minimum graphics memory usage is 256 MB)

Your system uses 256 MB RAM right off the bat for VRAM, leaving you with 1.7 GB RAM. Take another 650 MB RAM from that and you have 1.1 GB left for the client and any other processes running. You're almost certainly hitting swap like crazy, causing the system to lock up, which most definitely could cause WoW to stop responding.

The next time this happens, can you open your Console app (It's located in /Applications/Utilities/, select All Messages, and paste the messages in here that occur around the time of the crash? The Console app will often catch something that WoW's error reporter and Apple's Crash Reporter miss.

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
I am having the same error on a brand new MacBook Pro Retina with 16GB RAM and nVidia GeForce GT 650M with 1024MB VRAM. I can't get into the game to change any settings, as it quits as soon as I log on and is repeatable. Works fine on my wife's Mac Pro. I bought this computer because I could no longer raid on my iMac, so this is very distressing. Suggestions?

Edit: I should have read more carefully; once I fixed permissions, all was well. Thanks!

Join the Conversation

Return to Forum