Bugged Textures and Shadows

Technical Support
I'm having the same problem. I can't even play anymore due to the fact that my action bars are turning black and so are the dialog boxes when I speak with anyone.
I've also found that sometimes my X to close out of my map is a black square. A few other Xs and such do that, that's just one off the top of my head.

Edit: Just saw that my Game Menu has a black square over the "green screen" of the computer icon.
I am having this same problem, My character's face turns black, far away characters turn black, pretty much any shadow at more then point blank range is solid black. Turning down graphics seems to help some with this, however nothing will help the buttons turning solid black, and my action bars blacking out.
I have this problem as well. I put in a ticket and waited the three days for a response which was...

"We will gladly assist you with this issue. Here is a link on helping find your drivers: http://us.battle.net/support/article/200576 Here is some additional informaion on getting those drivers: http://support.amd.com/us/kbarticles/Pages/737-28041SupportforATIMobility.aspx

Lastly if updating your drivers doesn't fix the issue try this.

First, we are going to delete the Battle.net folder and also delete the WoW.mfil, WoW.tfil, and WoW.pfil files from the World of Warcraft folder. We will also need to go into the Data folder and delete the Cache folder. Then run the launcher.exe as Administrator by right clicking on the launcher.

This should clear up the problem you are having. If this does not resolve your issue contact me back for further support.

Have a great day. If you have any further questions or concerns feel free to contact us."

This did not fix the problem. I haven't put in a new ticket yet.
Damn, new patch did nothing
I have been experiencing the exact same problems you describe.
In order to fix this, I need to reset my multi-sampling by choosing a different level of MS. That corrects the problem until I enter an instance, or change zones.

At times I've even experienced an almost completely black screen.

I've changed drivers, and re-installed them, and finally just rolled back to my original driver to no avail.

I'm using a ATI Radeon HD5650 with 1GB video RAM.
Switching from DX11 to DX9 fixes this problem. Haven't had an issue since I did that.

Join the Conversation

Return to Forum