Framerate Issues

Mac Technical Support
Recently I just came back to WoW after about a half year long break. Now, before I left my game would run at about a steady 40-50 FPS with most of the graphic settings set at good to high. But ever since I started up again last week my game has been stuck at 12-15 FPS even if I turn all my settings down to fair. And even though I did a fresh install of the game, I cleared all my Cache, WTF, and Data folders anyways and it still didn't help. So after that I decided to upgrade my OS from 10.6.8 to 10.8 because 10.6 wasn't officially supported anymore. Still getting the same exact framerate.

So I'm wondering if there is anything at all I can do to get my game running back to the way it was, if this is going to be a future fix on Blizzard's part, or if this new expansion somehow is bonked on my computer.

Here's the specs on the system I'm running:

Software:

System Software Overview:

System Version: OS X 10.8.2 (12C54)
Kernel Version: Darwin 12.2.0
Time since boot: 45 minutes

Hardware:

Hardware Overview:

Model Name: iMac
Model Identifier: iMac11,2
Processor Name: Intel Core i5
Processor Speed: 3.6 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 4 MB
Memory: 16 GB
Processor Interconnect Speed: 6.4 GT/s
Boot ROM Version: IM112.0057.B00
SMC Version (system): 1.64f5

Graphics/Displays:

ATI Radeon HD 5670:

Chipset Model: ATI Radeon HD 5670
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: ATI (0x1002)
Device ID: 0x68c0
Revision ID: 0x0000
ROM Revision: 113-B9850H-133
EFI Driver Version: 01.00.416
Displays:
iMac:
Display Type: LCD
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Other:

Input Source ID: com.apple.keylayout.US
Keyboard Layout: ANSI

Join the Conversation

Return to Forum